AnsweredAssumed Answered

Access denied for guest on script execution (???)

Question asked by gc_yerbabuena on May 25, 2007
Latest reply on Nov 13, 2008 by kevinr
Hello everybody

I'm getting an AccessDeniedException when executing any script if the current user is "guest".

ERROR [util.transaction.SpringAwareUserTransaction] Transaction didn't commit
org.alfresco.repo.security.permissions.AccessDeniedException:

This is the scenario: I created a space (accessible for "guest") with an associated rule, which executes a script when any content is added to it.

I've tried several scripts ("test return value.js", "example test script.js"… even an empty script) but it keeps failing. The script does not even get to start.

I also tried to grant contributor, collaborator, etc. rights to user "guest" for the script document itself, but it doesn't work.

If I log in as "admin" it works. And if I disable the rule, the "guest" user can upload content without any problem. But I need to execute the script.

What am I doing wrong? I don't know what else to do.

Thank you.

PS: I didn't paste the call stack because it's almost 200 lines long, but if you think it could be useful, just tell me.

Outcomes