AnsweredAssumed Answered

Problems creating new content type

Question asked by bender22 on May 28, 2007
Latest reply on Jun 5, 2007 by bender22
Hi

I have some problems when i try to create a new content (and it's associated index page) following the example shown in WCM Evaluation Guide 2.0. To keep things simple, I imported the
"alfresco-demo-website.war" and use the same path (media/releases/content…) to put my new content as the PressRelease example.

The steps I followed are:

1) Create Content "my_content"
   1a) Create Web Form
   1b) Assign my_content.xsd as content definition
   1c) Assign my_content.xsl as template.
   1d) Finish without workflow

2) Create Content Bean
   2a) Download alfresco SDK
   2b) Create MyContentBean.java. Its content is copied from PressReleaseBean

3) Create Tag Library
   3a) Create cont.tld with the functions to get all the contents of type       
   "my_content" (the namespace is called "cont" instead of "pr").

Then I go to "Web Projects":

4) Go to the path: media\releases.  
   4a) I replace the current index.jsp (the one with PressRelease stuff) with a new one to render objects of type "my_content" calling methods declared in the .tld file.

5) Then I go to WEB-INF
   5a) Register "my_content.tld"
   5b) Put the MyContentBean.class file into WEB INF\lib\org\mycompany\cont

Finally when I click on index.jsp to view my new contents tomcat says "can't find org.mycompany.cont.MyContentBean specified in TLD".

I don´t know if I have forgotten anything or if the procedure used to show my new contents is incomplete (xsd  + xsl + class + tld + jsp).

The same error occurs for PressRelease when I delete "alfresco-demo-website.jar" and org\alfresco\web\pr\PressReleaseBean.class (the solution for this case its to do a new bulk import of "alfresco-demo-website.war").

I would like to know what is the relationship between alfresco-demo-website.war and alfresco-demo-website.jar and why my example doesn't work like PressRelease.

Thanks in advance.

Outcomes