AnsweredAssumed Answered

admin and hibernate problem

Question asked by shay on May 29, 2007
Latest reply on May 30, 2007 by kevinr
Hi,

I tried to build a new tree in the alfresco using the java APIs, starting with a new root space and adding some new sub trees recursively. after about 50 cycles i got the following exception:

java.lang.NoSuchMethodError: java.lang.Object.getHibernateLazyInitializer()Lorg/hibernate/proxy/LazyInitializer;

i've found this link on the net:
http://forums.alfresco.com/viewtopic.php?t=3148
which suggest to replace the hibenate jar, so i replaced the hibenate jar in my application (not in the alfresco web client) from hibernate-3.2.1.jar to hibernate3.jar and the problem solved, BUT…

When i tried to delete my new root space (which i created, not the company home)  via the alfresco web application, i got an exception and i had to restart the alfresco again.
after the 3 attempt i could not log in as admin and i got the following message:

The Home Space node referenced by Id: c114aa26-0db9-11dc-aa80-2fede2568e21 cannot be found. It may have been deleted from the database. Please contact your system administrator.


we use alfresco 2.0.0 and sdk-2.0.0 on linux


can you advice about:
how can i fix the admin problem? (can i recreate it? i tried to rebuild the indexs with index.recovery.mode=FULL but no luck)
which hibernate jar should i use with my application and which hibernate jar should i use with the alfresco web client?

this subject is very crucial and urgent to us since all of our content is in the alfresco and we cant reach it.

Thanks in advance,
Shay.

Outcomes