AnsweredAssumed Answered

[solved]problem while installing and restarting alfresco

Question asked by ahmetuslu on Sep 4, 2008
Latest reply on Sep 5, 2008 by ahmetuslu
Hi, I'm new in alfresco and I have some problems during the installations. I need help !!!

I'm using 2.9B version on Windows Server 2003 64bit edition with mysql 64bit edition.
My SQL part is ok, I have two problems as listed below.

— While starting Alfresco, it gives an error message about WinsockNetBIOSException, but it Alfresco works. After some investigation I learned that it is about CIFS access. But my users will use alfresco from web, is there any way to close this error or is it a problem ?

org.alfresco.filesys.netbios.win32.WinsockNetBIOSException: 10047:CreateDatagramSocket - Address family not supported by protocol family
   at org.alfresco.filesys.netbios.win32.Win32NetBIOS.CreateDatagramSocket(Native Method)
   at org.alfresco.filesys.netbios.win32.NetBIOSSocket.createDatagramSocket(NetBIOSSocket.java:162)
   at org.alfresco.filesys.smb.mailslot.WinsockNetBIOSHostAnnouncer.initialize(WinsockNetBIOSHostAnnouncer.java:103)
   at org.alfresco.filesys.smb.mailslot.HostAnnouncer.run(HostAnnouncer.java:270)

— My second problem is, after I installed and started alfresco firs time it works. But when I stop by using "alf_stop.bat" I can not start Alfresco again until I remove and setup the database files again by using "db_remove.bat" and "db_setup.bat". It gives

ERROR [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema auto-update failed
com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Table 'jbpm_action' already exists
   at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:936)
   at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2870)
   at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1573) ….

because alfresco tries to create database schemas for every start, it can not see the existing schemas from previous starts. So If I remove db and setup db again, all the users and content from previous start is deleted. Is there any way to not execute AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect.sql scripts while restarting Alfresco.

I'm in trouble with these errors and any help will be a sunlight for me :)

-thanks in advance.

Outcomes