AnsweredAssumed Answered

Err: 'The node's content is missing' in a Rollback

Question asked by qasimh on Jun 6, 2007
Latest reply on Apr 17, 2008 by luã­smiguelsequeira
Hi,

I use Alfresco 2.0 CE on Windows 2003 Server, Tomcat, JDK 1.5, and MS SQL Server. 

I am trying to come up with a disaster recovery process for Alfresco and its content.  This means I want to be able to restore Alfresco and its contents to a previously backed up version (a "Roll-back"). 
The following resources are backed up: 
- Tomcat folder
- alf_data folder
- MS SQL Server

After the roll-back and restart, I start getting the following error message for some content when viewing it in the webclient:

The node's content is missing:
   node: workspace://SpacesStore/f02d29ba-f8f1-11db-9568-934a28c0cd8d
   reader: ContentAccessor[ contentUrl=store://2007/5/31/7/38/e558f469-0f73-11dc-bfad-cfcaced7c0f0.bin, mimetype=text/html, size=0, encoding=UTF-8] 
Please contact your system administrator.

The properties in the webclient are fine, but the content itself is missing.  This means the metadata in the DB is fine, but the file is missing from the alf_data filestore.  Examining the files in alf_data, I see that the content was infact missing for some reason.  I restore another version of alf_data and copy over the missing files.

But that does not appear to fix anything.  I can see the content fine from the "Node Browser", searching for noderef "workspace://SpacesStore/f02d29ba-f8f1-11db-9568-934a28c0cd8d", but it does not work from anywhere else.

Can someone help me refine this process, or tell me if I'm doing something wrong?  I can't find a repeatable process that will allow me recover content.

Outcomes