AnsweredAssumed Answered

Problem with ftp to list a directory

Question asked by agey on Sep 8, 2008
Latest reply on Dec 11, 2008 by mikew
Hello all,

I wanted to use the connection ftp of Alfresco to upload files to the spaces. I use the version Alfresco 2.9C on Windows XP and MySQL Server 5.0. Alfresco is enabled for multi tenant.

I can connect to the ftp server of Alfresco and then list the directory. Returns two directories: Alfresco and AVM. When I want to enter the directory Alfresco, returns the error 550 Invalid path Alfresco but I can enter the directory AVM and list it correctly. Also, if in Alfresco exists a directory "spaceA" and I try to enter with the path /Alfresco/spaceA, then I can enter and lists it correctly. Which can be the problem? Why cannot I enter Alfresco and list it to see the spaces that exist in?

This one is the result returned in the console of windows:

230 User logged in, proceed
ftp>   ls
200 PORT OK
150 File status okay, about to open data connection
Alfresco
AVM
226 Closing data connection
ftp:15 bytes recibidos en 0,00 segundos 15000,00 a KB/s
ftp>cd Alfresco
550 invalid path Alfresco
ftp>cd Alfresco/"Departamento It"
250 Requested file action OK
ftp>ls
200 Port OK
150 File status okay, about to open data connection
Documentacion tecnica
Versiones
226 Closing data connection

And this one is the result returned in the Filezilla:

Respuesta:   230 User logged in, proceed
Comando:   OPTS UTF8 ON
Respuesta:   200 OPTS UTF8 ON
Estado:   Conectado
Estado:   Recuperando el listado del directorio…
Comando:   PWD
Respuesta:   257 "/"
Comando:   TYPE I
Respuesta:   200 Command OK
Comando:   PASV
Respuesta:   227 Entering Passive Mode (192,168,2,11,6,100)
Comando:   LIST -a
Respuesta:   150 File status okay, about to open data connection
Respuesta:   226 Closing data connection
Estado:   Directorio listado correctamente
Estado:   Recuperando el listado del directorio…
Comando:   CWD Alfresco
Respuesta:   550 Invalid path Alfresco
Error:   Error al recuperar el listado del directorio


The configuration of FTP Server in the file-server.xml is the following:

   <config evaluator="string-compare" condition="FTP Server">
     <serverEnable enabled="true"/>
    
     <!– Run on a non-privileged port –>
     <port>21</port>

   <!– path of the root directory –>
   <rootDirectory>/Alfresco/</rootDirectory>
      <!– FTP authentication –>
      <authenticator type="alfresco"/>
          
<!–      <debug flags="File,Search,Error,Directory,Info,DataPort"/> –>
   </config>


Can someone help me with this problem? It is very important and urgent.

Thanks in advance.

Outcomes