AnsweredAssumed Answered

Exception in Virtual-Tomcat

Question asked by darran on Jun 13, 2007
Latest reply on Aug 2, 2007 by sacco
Hi,
I`m using Windows Vista Business.

I`ve installed Enterprise Alfresco 201 and WCM 201.

I`ve installed the virtual-tomcat as a service after reading http://forums.alfresco.com/viewtopic.php?t=5858
and all the related links.

And I`m ensuring that my Virtual-server starts after my main Alfresco installation but I`m still getting the following exception in my virtual-tomcat:-

SEVERE: Exception starting filter alfrecoCacheControlFilter
java.lang.NullPointerException
   at org.alfresco.filter.CacheControlFilter.Init(CacheControlFilter.java:94)
   at org.alfresco.filter.CacheControlFilter.init(CacheControlFilter.java:65)
   at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:223)
   at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(ApplicationFilterConfig.java:304)
   at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:77)
   at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:3634)
   at org.apache.catalina.core.StandardContext.start(StandardContext.java:4217)
   at org.alfresco.catalina.context.AVMStandardContext.start(AVMStandardContext.java:71)
   at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
   at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739)
   at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
   at org.alfresco.catalina.host.AVMHostConfig.deployAVMdirectory(AVMHostConfig.java:1402)
   at org.alfresco.catalina.host.AVMHostConfig.deployAVMWebapp(AVMHostConfig.java:1201)
   at org.alfresco.catalina.host.AVMHostConfig.deployAVMWebappDescriptorTree(AVMHostConfig.java:1047)
   at org.alfresco.catalina.host.AVMHostConfig.deployAVMWebappDescriptorTree(AVMHostConfig.java:1056)
   at org.alfresco.catalina.host.AVMHostConfig.deployAVMWebappsInDependencyOrder(AVMHostConfig.java:1040)
   at org.alfresco.catalina.host.AVMHostConfig.deployAllAVMwebappsInRepository(AVMHostConfig.java:403)
   at org.alfresco.catalina.host.AVMHostConfig.deployApps(AVMHostConfig.java:244)
   at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1122)
   at org.alfresco.catalina.host.AVMHostConfig.start(AVMHostConfig.java:196)
   at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:310)
   at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1021)
   at org.apache.catalina.core.StandardHost.start(StandardHost.java:718)
   at org.alfresco.catalina.host.AVMHost.start(AVMHost.java:632)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1013)
   at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:442)
   at org.apache.catalina.core.StandardService.start(StandardService.java:450)
   at org.apache.catalina.core.StandardServer.start(StandardServer.java:709)
   at org.apache.catalina.startup.Catalina.start(Catalina.java:551)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:585)
   at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:294)
   at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:432)

Any ideas why??

Thanks

Darran

Outcomes