AnsweredAssumed Answered

Excel not indexed in Alfresco 2.9B and 3.0B

Question asked by gfeguiguren on Sep 16, 2008
Latest reply on Sep 18, 2008 by gfeguiguren
Hi everybody!

First of all I would like to congratulate this excellent community and product  :D , is the only one open source ECM project  that offers a complete set of features: Office plugins,  WebDav, CIFS, Web scripts….  at no cost and quality documentation.

I´m integrating some small application in PHP using phpIntegration.amp library with Alfresco2.9b , right now is working, but I realized in testing that the content of the Excel files (most of them Excel 2003 format) are not indexed or not appearing in search results.

Then I thought it could be related with some mistake in the code. So I started to upload excel files directly in the Alfresco Web Interface, and still the problem persist. When I search for a phrase or a word (that is inside the excel file ) using standard and advanced mode of the web interface, I didn´t get any result. I have tried with various excel files (2003 format) and I´m not getting them as result of the search in the alfresco web interface results.

Then I tried with the new version 3.0B and is the same.  Actually I realized that the search of phrases inside some pdf files are also not working.
In fact I think that just word files are being corrected indexed and appear in the search results when you look for a phrase inside them.

My testing environment  is : Windows XP SP2, MySql 5.0.45-community-nt,  Apache 2.2.4  and I’m using the tomcat bundles of Alfresco 2.9B and 3.0B 

I will appreciate any help and suggestions around this.

Thanks in advance for your kind and valuable help

Regards,

Gabriel

Outcomes