AnsweredAssumed Answered

Using the Web services interface

Question asked by ucorda on Sep 17, 2008
Latest reply on Dec 18, 2009 by samir_raut34
I have been trying to use the Web services interface, but I have encountered a few difficulties

1) There is a mismatch between the implementation status as defined at http://wiki.alfresco.com/wiki/Alfresco_Draft_Implementation_Status and the actual operations made available via the WSDL files. For example, RepositoryService.wsdl declares 4 operations, while the implementation status document lists more than 4 and at the same time does not list getRepositories (which is included in the wsdl file)

2) I tried the getRepositories operation, by sending out this SOAP message:

<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:q0="http://www.cmis.org/2008/05" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <soapenv:Body>
    <q0:getRepositories/>
  </soapenv:Body>
</soapenv:Envelope>

but I receive the following SOAP fault response:

<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<wsse:Security xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">
      <wsu:Timestamp xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" wsu:Id="Timestamp-23366617">
        <wsu:Created xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">2008-09-16T23:24:41.031Z</wsu:Created>
        <wsu:Expires xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">2008-09-16T23:29:41.031Z</wsu:Expires>
      </wsu:Timestamp>
    </wsse:Security>
  </soap:Header>
  <soap:Body>
    <soap:Fault>
      <faultcode xmlns:ns1="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">ns1:InvalidSecurity</faultcode>
      <faultstring>An error was discovered processing the &lt;wsse:Security&gt; header</faultstring>
    </soap:Fault>
  </soap:Body>
</soap:Envelope>

(not sure where the wsse header is coming from)

3) I tried to use getRepositoryInfo, which requires the input parameter repositoryID, but I have no idea where to get that information from. I set up my Alfresco server following exactly the Alfresco Tutorial PDF document. How do I get a repositoryID using the Web GUI?

Outcomes