AnsweredAssumed Answered

Lab3 Install: valid SecureContext was not provided [SOLVED]

Question asked by norgan on Sep 19, 2008
Latest reply on Nov 3, 2008 by shoshin
Hello crew,

following setup
  • Suse Enterprise Linux 10 Sp1

  • Mysql 5.0.26

  • Alfresco-Labs-Linux-Setup for 30b (August Edition)

  • OpenOffice2.3 on /opt/openoffice/
Following Installation Steps
  • cp soffice.bin soffice.exe (else, installer wont accept directory selection and proceed on "NEXT"

  • execute installer and install full alfresco on /opt/alfresco

  • switch to mysql and install DB

  • wcm extension according to wiki

  • install apply_amps for packages

  • install ROOT.war in tomcat/webapps
Starting :
  • /opt/alfresco/alfresco.sh start

  • Bug 1: In Catalina.out
    12:05:05,571  ERROR [util.exec.RuntimeExecBootstrapBean] Bootstrap command failed:
    Execution result:
       os:         Linux
       command:    "/opt/openoffice.org2.3/program/soffice" "-accept=socket,host=localhost,port=81
    00;urp;StarOffice.ServiceManager" "-env:UserInstallation=file:////opt/openoffice.org2.3" -nolo
    go -headless -nofirststartwizard -nocrashrep -norestore
       succeeded:  false
       exit code:  2
       out:
       err:        java.io.IOException: "/opt/openoffice.org2.3/program/soffice": not found

    Bug 2: http://localhost:8080/ results in
    HTTP Status 500 -

    type Exception report

    message

    description The server encountered an internal error () that prevented it from fulfilling this request.

    exception

    javax.servlet.ServletException
       org.alfresco.proxy.ProxyServlet.service(ProxyServlet.java:103)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

    root cause

    java.lang.reflect.InvocationTargetException
       sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       java.lang.reflect.Method.invoke(Method.java:585)
       org.alfresco.proxy.ProxyServlet.service(ProxyServlet.java:99)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

    root cause

    org.alfresco.module.vti.VtiInternalErrorException: net.sf.acegisecurity.AuthenticationCredentialsNotFoundException: A valid SecureContext was not provided in the RequestContext
       org.alfresco.module.vti.handler.alfresco.AlfrescoVtiMethodHandlerThrowsAdvice.afterThrowing(AlfrescoVtiMethodHandlerThrowsAdvice.java:53)
       sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       java.lang.reflect.Method.invoke(Method.java:585)
       org.springframework.aop.framework.adapter.ThrowsAdviceInterceptor.invokeHandlerMethod(ThrowsAdviceInterceptor.java:146)
       org.springframework.aop.framework.adapter.ThrowsAdviceInterceptor.invoke(ThrowsAdviceInterceptor.java:131)
       org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:166)
       org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:204)
       $Proxy81.existResource(Unknown Source)
       org.alfresco.module.vti.VtiFilter.doFilter(VtiFilter.java:184)
       org.alfresco.module.vti.httpconnector.VtiServletContainer$HttpFilterChain.doFilter(VtiServletContainer.java:273)
       org.alfresco.module.vti.httpconnector.VtiServletContainer.service(VtiServletContainer.java:133)
       sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       java.lang.reflect.Method.invoke(Method.java:585)
       org.alfresco.proxy.ProxyServlet.service(ProxyServlet.java:99)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

    root cause

    net.sf.acegisecurity.AuthenticationCredentialsNotFoundException: A valid SecureContext was not provided in the RequestContext
       net.sf.acegisecurity.intercept.AbstractSecurityInterceptor.credentialsNotFound(AbstractSecurityInterceptor.java:477)
    [EDIT] Solved : incorret ROOT.war was copied.


    Bug 3: Share wont allow a log in for admin/admin
    The remote server may be unavailable or your authentication details have not been recognised.

    [EDIT] Solved : Port 8080 is needed or lots of hardcoded changing


    Thanks in advance,
    Norgam

    Outcomes