AnsweredAssumed Answered

Type does not show up in Content Wizards

Question asked by vikram on Jun 27, 2007
Latest reply on Oct 17, 2007 by stiegld
Hi Everyone,

First of all its nice to see such a quality open source software building up! congrats to all!

A have a little problem. My new "type" will not show up in the "Content Wizards" type selectbox.

Here is the code:

web-client-config-custom.xml

<alfresco-config>

   <!–  add someco types to add content list –>
   <config evaluator="string-compare" condition="Content Wizards">
      <content-types>
         <type name="fivee:interactiveMaps" />
      </content-types>
   </config>

</alfresco-config>



mapImageModel.xml

<?xml version="1.0" encoding="UTF-8"?>
<!– Definition of new Model –>
<model name="fivee:mapImageModel" xmlns="http://www.alfresco.org/model/dictionary/1.0">

   <!– Optional meta-data about the model –>
   <description>Map Model</description>
   <author>Vikram Mandal</author>
   <version>1.0</version>

   <!– Imports are required to allow references to definitions in other models –>
   <imports>
      <!– Import Alfresco Dictionary Definitions –>
      <import uri="http://www.alfresco.org/model/dictionary/1.0" prefix="d" />
      <!– Import Alfresco Content Domain Model Definitions –>
      <import uri="http://www.alfresco.org/model/content/1.0" prefix="cm" />
   </imports>

   <!– Introduction of new namespaces defined by this model –>
   <namespaces>
      <namespace uri="http://www.fivee.in/model/content/1.0" prefix="fivee" />
   </namespaces>

   <types>
      <!– Enterprise-wide generic document type –>
      <type name="fivee:interactiveMaps">
         <title>Map Document</title>
         <parent>cm:content</parent>
      </type>
   </types>
</model>

map-reference-model-context.xml

<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>
    <!– Registration of new models –>
    <bean id="extension.dictionaryBootstrap" parent="dictionaryModelBootstrap" depends-on="dictionaryBootstrap">
        <property name="models">
            <list>
                <value>alfresco/extension/mapImageModel.xml</value>
            </list>
        </property>
    </bean>
</beans>


I am using Alf 2.0
Thanks in advance for help.

Outcomes