AnsweredAssumed Answered

Problem migrating form 2.0 to 2.1 with Mysql on linux

Question asked by jey on Jul 5, 2007
Latest reply on Oct 4, 2007 by derek
Hi,

I have notice some kind of a bug during the database schema update.

I have two environment: one on linux (SLES) and the other on windows xp.
Both use mysql.


On my windows environment the migration worked fine.

On my linux environment, tables related to JBPM add been created in uppercase in mysql, and the schema update script is looking for lowercase table names!
So the update failed!

For information: on my windows environment all the table had been created in lowercase!

SO I have try to modify all the table in uppercase to lowercase ! Long work … But it still doesn't work ! Now there is issues with the column names….

This is quite disturbing !!!"SO I reverted to my last backup and I am still using version 2.0

Should I raise an issue in JIRA or anyone can tell me where does this error comes from and how to solve it? (I am affraid of having many issue if I just try to change all cases).

Regards,
Jey.

Outcomes