AnsweredAssumed Answered

Lucene 2.3.2

Question asked by muralihb on Oct 9, 2008
hi

         i am trying to replace the lucene 2.1.0 jar file with latest lucene 2.3.2 jar in the firstfoundation sample available in the SDK. the following error msg has been occured.

ERROR:
java.lang.ExceptionInInitializerError

Caused by: java.io.IOException: Cannot delete D:\alf_data\lucene-indexes\user\alfrescoUserStore\16b91a2e-95e2-11dd-8553-d504c1a99108\segments_1
at org.apache.lucene.store.FSDirectory.deleteFile(FSDirectory.java:351)
at org.apache.lucene.index.SegmentInfos.write(SegmentInfos.java:309)
at org.apache.lucene.index.IndexWriter.init(IndexWriter.java:708)
at org.apache.lucene.index.IndexWriter.<init>(IndexWriter.java:478)
at org.alfresco.repo.search.impl.lucene.index.IndexInfo.makeDeltaIndexWriter(IndexInfo.java:754)
at org.alfresco.repo.search.impl.lucene.index.IndexInfo.getDeltaIndexWriter(IndexInfo.java:794)
at org.alfresco.repo.search.impl.lucene.AbstractLuceneBase.getDeltaWriter(AbstractLuceneBase.java:219)
at org.alfresco.repo.search.impl.lucene.AbstractLuceneIndexerImpl.indexImpl(AbstractLuceneIndexerImpl.java:626)
at org.alfresco.repo.search.impl.lucene.AbstractLuceneIndexerImpl.indexImpl(AbstractLuceneIndexerImpl.java:657)
at org.alfresco.repo.search.impl.lucene.AbstractLuceneIndexerImpl.flushPending(AbstractLuceneIndexerImpl.java:789)

plz let me know.. any solution available…

Outcomes