AnsweredAssumed Answered

Labs3B (Sept 10 08 version) on JBoss 4.2.2.GA

Question asked by clburnett on Oct 10, 2008
Latest reply on Oct 12, 2008 by norgan
Just thought I would post this after a round of troubleshooting to get the latest Labs 3B running on JBoss 4.2.2.GA.  I am not an expert on this, but just wanted to summarize for those who may be interested.  The first two steps are typical.  The last step was necessary to resolve a deployment issue with JBoss 4.2.2.GA.

1. When copying the exploded war from tomcat\webapps\ to jbossHome\server\default\deploy , make sure you name the alfresco folder to alfresco.war

2. Copy any custom extension definition files from tomcat\shared\classes\alfresco to jbossHome\server\default\conf\alfresco

3. Copy saar.jar, saar-api-1.3.jar and saar-impl-1.3.jar from tomcat\webapps\alfresco\WEB-INF\lib to jbossHome\lib\endorsed folder.  This was the error that was so puzzling.  I am guessing that the jboss-saar.jar has issues, so by endorsing the working tomcat jars, that seemed to bypass the faulting jboss-saar.jar culprits.  I'm not sure this is the right way to fix JBoss' inability to create the message factory for SOAP, but it seems to have worked for now.  (I got this lead from forum at http://forum.springframework.org/showthread.php?t=47858  post on 7/2/08 from sandhya)

Craig

Outcomes