AnsweredAssumed Answered

Problem with patch.webScriptsReadme when upgrading to 2.1

Question asked by lme on Jul 17, 2007
Latest reply on Jul 31, 2007 by lme
Hi,

I'm currently trying to upgrade from 2.0 to 2.1. There is a problem with the patch webScriptsReadme :
=== Impossible d'appliquer le correctif          ===
ID : patch.webScriptsReadme
RESULTAT :
org.alfresco.error.AlfrescoRuntimeException: Bootstrap failed
        at org.alfresco.repo.importer.ImporterBootstrap.bootstrap(ImporterBootstrap.java:444)
        at org.alfresco.repo.admin.patch.impl.GenericBootstrapPatch.applyInternal(GenericBootstrapPatch.java:126)
        at org.alfresco.repo.admin.patch.AbstractPatch$1$1.doWork(AbstractPatch.java:351)
        at org.alfresco.repo.admin.patch.AbstractPatch$1$1.doWork(AbstractPatch.java:345)
        at org.alfresco.repo.transaction.TransactionUtil.executeInTransaction(TransactionUtil.java:189)
        at org.alfresco.repo.transaction.TransactionUtil.executeInNonPropagatingUserTransaction(TransactionUtil.java:127)
        at org.alfresco.repo.admin.patch.AbstractPatch$1.doWork(AbstractPatch.java:357)
        at org.alfresco.repo.admin.patch.AbstractPatch$1.doWork(AbstractPatch.java:341)
        at org.alfresco.repo.security.authentication.AuthenticationUtil.runAs(AuthenticationUtil.java:260)
        at org.alfresco.repo.admin.patch.AbstractPatch.apply(AbstractPatch.java:360)
        at org.alfresco.repo.admin.patch.PatchService…

and

Caused by: org.alfresco.service.cmr.view.ImporterException: Failed to import package at line 3; column 1251 due to error: Node does not exist: workspace://SpacesStore/d67d0884-343d-11dc-951d-a74fda397a1d
        at org.alfresco.repo.importer.view.ViewParser.parse(ViewParser.java:189)
        at org.alfresco.repo.importer.ImporterComponent.parserImport(ImporterComponent.java:360)
        at org.alfresco.repo.importer.ImporterComponent.importView(ImporterComponent.java:224)
        at org.alfresco.repo.importer.ImporterBootstrap.bootstrap(ImporterBootstrap.java:426)
        … 59 more
Caused by: org.alfresco.service.cmr.repository.InvalidNodeRefException: Node does not exist: workspace://SpacesStore/d67d0884-343d-11dc-951d-a74fda397a1d
        at org.alfresco.repo.node.db.DbNodeServiceImpl.getNodeNotNull(DbNodeServiceImpl.java:131)
        at org.alfresco.repo.node.db.DbNodeServiceImpl.getType(DbNodeServiceImpl.java:508)
        at sun.reflect.GeneratedMethodAccessor139.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)


It seems that the two spaces Web Scripts and Web Scripts Extensions are not created in the Data Dictionnary before applying the webScriptsReadme patch. So, the patch failed to add the readme.ftl template.

Let me know if you need the complete stacktrace.

Outcomes