AnsweredAssumed Answered

ReferenceError: 'avm' is not defined

Question asked by rafalp75 on Jul 17, 2007
Latest reply on Jul 18, 2007 by kevinr
Hi,

I'm trying to run javascript for AVM (I've run example from http://wiki.alfresco.com/wiki/JavaScript_API#Search_API). I have following error:
Caused by: org.mozilla.javascript.EcmaError: ReferenceError: "avm" is not defined. (AlfrescoScript#39)
   at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3226)
   at org.mozilla.javascript.ScriptRuntime.constructError(ScriptRuntime.java:3216)
   at org.mozilla.javascript.ScriptRuntime.notFoundError(ScriptRuntime.java:3289)
   at org.mozilla.javascript.ScriptRuntime.name(ScriptRuntime.java:1567)
   at org.mozilla.javascript.Interpreter.interpretLoop(Interpreter.java:3161)
   at org.mozilla.javascript.Interpreter.interpret(Interpreter.java:2250)
   at org.mozilla.javascript.InterpretedFunction.call(InterpretedFunction.java:149)
   at org.mozilla.javascript.ContextFactory.doTopCall(ContextFactory.java:337)
   at org.mozilla.javascript.ScriptRuntime.doTopCall(ScriptRuntime.java:2755)
   at org.mozilla.javascript.InterpretedFunction.exec(InterpretedFunction.java:160)
   at org.mozilla.javascript.Context.evaluateReader(Context.java:1163)
   at org.alfresco.repo.jscript.RhinoScriptService.executeScriptImpl(RhinoScriptService.java:244)
   … 40 more

I have installed Alfresco (Community Network): Current version 1.4.0 (build-105) schema 21

Could anyone help me with this issue?

Thanks Rafal

Outcomes