AnsweredAssumed Answered

Problem acessing custom content model in dev environment

Question asked by risenhoover on Oct 15, 2008
Latest reply on Jul 9, 2012 by imzak82
Hi All,

I am starting to write some Java classes that will run within the JVM of Alfresco, and in order to simplify the process, I'm using the EmbeddedServer driven by the JUnit testing framework.  I've made some great progress with this, and have been able to search through the repository, find nodes, etc.

My problem is that when I try to create a node that has a custom type that I've defined, I get an error that says "Class {xx}xx has not been defined in the data dictionary.  Of course it is, and I can confirm it by firing up Alfresco in the tomcat environment and creating nodes that are that type, but when I use the embedded server, this type isn't found.

I've tried moving my custom model definition file out of the ./shared/… tree and directly into the alfresco tree.  I've tried adding it to the bootstrap services, I've tried lots of things, but no matter what, it's not found.

Any advice would be appreciated.
Paul

Outcomes