AnsweredAssumed Answered

Import (multiple roots error)

Question asked by letom on Oct 17, 2008
Latest reply on Mar 19, 2009 by dwilson
Hi.

im trying to restore a space store export.
the import process via the command line tool works fine.
It tells me everything is imported. no error.
I try to boot up alfresco again and i get an error

org.alfresco.filesys.server.core.DeviceContextException: Multiple possible roots for device:
   root path: /app:company_home
   results: [workspace://SpacesStore/667573ad-73ca-484b-b2f4-3b69e0510cfc, workspace://SpacesStore/56792686-a0b0-11db-b25c-e96b2cdb98c8]

ive deleted the alf_data content before restoring and i deleted the database. Same problem.
ive also tried to delete the first key (the old one, cos its not in the export file) from the database, but i cant cant cos its a primary key, foreign contrain blah blah.
Ive also tried to -uuidBinding REPLACE_EXISTING in the import *.bat but nothing, still the same error.

Now im guessing its because alfresco cant seem to be able to choose between the older (which shouldnt be there) root folder and the newer one.
Is there somewhere where i can change this setting so it chooses one or the other, or any other fix.

Please help.

Alfresco enterprise 2.2 sp1
Windows vista 32bit
tomcat, java 1.6

Outcomes