AnsweredAssumed Answered

Applet inside an Amp

Question asked by lucagia on Oct 30, 2008
Latest reply on Nov 7, 2008 by lucagia
Hi all.
I'm developing an amp that includes a jsp, which has inside an applet (which points to a rest interface).
The jsp is mapped to /alfresco/jsp/sign/sign.jsp.

My problem is that I get an error when going to the jsp page … saying that the applet is "notinitiated" (the page works correctly but not the applet).

I've put the applet jar inside the lib folder of my amp, and so it's deployed to /alfresco/WEB-INF/lib. But it is not working.
    <applet code="org.myapplet.Applet" archive="applet.jar" WIDTH="0" HEIGHT="0" ID="applet" VIEWASTEXT
             style="visibility:visible" MAYSCRIPT scriptable>
            <PARAM NAME = "user" VALUE="just_to_try"/>
            <NOAPPLET>Unable to load applet</NOAPPLET>
    </applet>


I also tried to change the archive path to
archive="../../WEB-INF/lib/applet.jar" but it's still the same.

The applet is ok … cause I've tried the same jsp with the same applet in Jetty and it works without problems.

Thanks in advance

Outcomes