AnsweredAssumed Answered

Ubuntu install issues, or bugs?

Question asked by loonsailor on Oct 31, 2008
Latest reply on Feb 14, 2009 by mr.adthinh
I installed labs 3.0b on ubuntu 8.04.  It works pretty well, which is kind of amazing considering that it's an 800Mhz, 512MB system (a new one shows up next week).  However, there are a few issues, and I'm not sure whether they're install problems or bugs.  Just for completeness, and for the next guy, I'll note a couple of things that I've already fixed.  I'm currently using the built-in derby database, rather than mySql.  (is there a good reason to switch soon?) 

The error messages are from alfresco.log.  I'm not sure if there are other logs that I should be checking. 

[size=125]1. pdf2swf[/size]
I was getting an error about pdf2swf:
 ERROR [org.alfresco.repo.content.transform.swf.PDFToSWFContentTransformer] Failed to start SWF2PDF transformer: 
Execution result:
   os:         Linux
   command:    pdf2swf -V
   succeeded:  false
   exit code:  1
   out:       
   err:        Cannot run program "pdf2swf": java.io.IOException: error=2, No such file or directory
I installed swftools (with synaptics) and no longer get this error.


[size=125]2. OpenOffice / file conversion[/size]
I'm having problems with OpenOffice.  I was getting this error:
ERROR [org.alfresco.util.exec.RuntimeExecBootstrapBean] Bootstrap command failed: 
Execution result:
   os:         Linux
   command:    "/usr/bin/soffice" "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" "-env:UserInstallation=file:////usr/local/Alfresco" -nologo -headless -nofirststartwizard -nocrashrep -norestore
   succeeded:  false
   exit code:  2
   out:       
   err:        Cannot run program ""/usr/bin/soffice"": java.io.IOException: error=2, No such file or directory
I modified tomcat/shared/classes/alfresco/extension/bootstrap/openoffice-startup-context.xml, fixing the line that starts soffice so that it's now
<value><![CDATA[/usr/bin/soffice "-accept=socket…
The error is no longer logged, but I still get the following warning message:

09:20:30,494 WARN  [org.alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established.
I wouldn't worry about the warning, except that I can't seem to do a .doc to .pdf conversion, and I suspect that the lack of connection to OpenOffice is the reason.  When I try to convert name.doc to a pdf (show details / run action / transform and copy content) it makes a file called name.pdf, but it's still a word file, of identical size to the original.  It seems that the file is just being copied and rename instead of being transformed.


[size=125]3. Info / details bug[/size]
Those first two seem like installation problems, but the last thing seems like a bug to me.  Clicking the "details" icon from the "information" box doesn't work.  When I'm browsing the space, click "i" then click the "details" icon, it goes to a blank page.  When I'm looking at a file with the "My Spaces List" widget in my dashboard and I click "i" then "details", a new firefox tab appears, then instantly disappears.  However, when I click the "details" icon beneath the file while browsing the space (rather than from the information box) it works fine.

Thanks, in advance, for any help with these issues.  Of course, the nicest thing will be when the slfresco ubuntu package is complete, and all will magically just work!

Outcomes