AnsweredAssumed Answered

out of memory, and other errors on ubuntu

Question asked by greenmoss on Nov 4, 2008
Latest reply on Nov 17, 2009 by danna
Hey all,

I managed to install Alfresco according to the documentation at these urls:

http://wiki.alfresco.com/wiki/Installing_Alfresco_on_Ubuntu_7.10
http://wiki.alfresco.com/wiki/Installing_Alfresco_on_Ubuntu_8.04

I ran the init script, and saw it do the setup. I also see the mysql tables it created. However, I'm getting various errors. Attaching logs, minus (what looks to me like) stack traces:

Tue Nov  4 16:50:13 EST 2008 Starting Alfresco …
16:51:07,338 INFO  [org.alfresco.config.xml.XMLConfigService$PropertyConfigurer] Loading properties file from class path resource [alfresco/file-servers.properties]
16:51:33,769 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
16:51:35,158 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] No changes were made to the schema.
16:51:38,472 ERROR [org.alfresco.util.exec.RuntimeExecBootstrapBean] Bootstrap command failed:
Execution result:
   os:         Linux
   command:    "soffice" "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" "-env:UserInstallation=file://oouser" -nologo -headless -nofirststartwizard -nocrashrep -norestore
   succeeded:  false
   exit code:  2
   out:       
   err:        Cannot run program ""soffice"": java.io.IOException: error=2, No such file or directory
16:51:40,114 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: /var/lib/alfresco/alf_data
16:51:40,183 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
16:51:40,574 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] No patches were required.
16:51:40,953 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 0 module(s).
16:51:41,468 ERROR [org.alfresco.smb.protocol] Failed to get local domain/workgroup name, using default of WORKGROUP
16:51:41,468 ERROR [org.alfresco.smb.protocol] (This may be due to firewall settings or incorrect <broadcast> setting)
16:51:44,470 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_07-b06; maximum heap size 494.938MB
16:51:44,470 WARN  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - WARNING - maximum heap size 494.938MB is less than recommended 512MB
16:51:44,471 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (b 1164) schema 131 - Installed version 3.0.0 (b 1164) schema 131
16:52:03,460 ERROR [org.alfresco.config.BaseConfigService] Input stream invalid - skipped for source: classpath:alfresco/web-client-config-dialogs.xml'
org.alfresco.config.ConfigException: Failed to parse config stream
Caused by: java.lang.OutOfMemoryError: PermGen space
16:52:07,090 ERROR [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/alfresco]] StandardWrapper.Throwable
java.lang.OutOfMemoryError: PermGen space
16:52:07,092 ERROR [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/alfresco]] Servlet /alfresco threw load() exception
java.lang.OutOfMemoryError: PermGen space
16:52:08,510 ERROR [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/alfresco]] StandardWrapper.Throwable
java.lang.OutOfMemoryError: PermGen space
16:52:10,146 ERROR [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/alfresco]] Servlet /alfresco threw load() exception
java.lang.OutOfMemoryError: PermGen space



I tried twiddling various memory configuration parameters to no avail, as detailed in these posts:
http://forums.alfresco.com/en/viewtopic.php?f=8&t=14228&p=46862
http://forums.alfresco.com/en/viewtopic.php?f=3&t=14451


What's wrong with my setup?

Outcomes