AnsweredAssumed Answered

NFS CLIENT

Question asked by nerolauda2 on Aug 1, 2007
Latest reply on Mar 17, 2008 by wtberks
I cannot find a way for NFS client  to work good.
This is the more stable configuration i found:
in file-servers-xml

   <config evaluator="string-compare" condition="NFS Server">
     <serverEnable enabled="true"/>
     <MountServerPort>1678</MountServerPort>
     <NFSServerPort>12049</NFSServerPort>

     <rpcAuthenticator>
        <userMappings>
          <user name="admin" uid="0" gid="0"/>
          <user name="admin" uid="1000" gid="100"/>
          <user name="admin" uid="1000" gid="0"/>
         </userMappings>
     </rpcAuthenticator>

   </config>

mount command:
mount -t nfs -o hard,nointr,tcp,retrans=45,retry=1,timeo=20,nolock,mountport=1678,port=12049  10.0.0.99:/alfresco /alfresco

it mounts correctly in TCP
but when i try to work in my new mounted directory something strange happens.
when i copy files it happens the following (cp /somedir/* /alfresco/somedir.) :
cp: closing `./filename.ext': Unknown error 526

and it happens on many files.
Moreover some of the files on which the error occurred surprisingly have correctly been copied.
Some other are with length 0 bytes and some else have not been copied.
Moreover after such a copy also some ls give as result:
/bin/ls: reading directory .: Unknown error 526
but soon after it works.

I also tried a rsync, but the result was disastrous.
I tried a lot of different mounting options but I didn't find any working.
During a cp trial I also have had to hard reset the server because it has gone out of memory.
And some other times i have had to restart the tomcat because in the web client i saw a situation and with the NFS client i saw a totally different think and it was wrong and i unmounted and remounted, but nothing changed. As i restarted there where congruence again.
There are also problems with special character such as "òàù%" and others. They are replaced with '?' and the files with this character cannot be deleted. But they can be renamed and then deleted.

It seems to me that this client must be tuned in some way.
Moreover this client has no security features, that is that everybody on the net can mount it and it logs as admin …
I cannot use it as it is. I prefer to use the more stable FTP client actually.

regards

Outcomes