AnsweredAssumed Answered

Plain text conversion failed when enters found

Question asked by simon on Aug 2, 2007
Latest reply on Aug 3, 2007 by derek
Alf,

Think we found a bug in the conversion of plain text files to PDF. Not sure if this is something OpenOffice related or Alfresco but maybe someone could confirm this.

1. If we upload a plain text file without enters everything works fine (tried a one word file and a file with a few 100 words, both work).

2. If we upload the same file with enters it fails.

Tried it in Alfresco 1.4 Enterprise and 2.1 Community with OpenOffice 2.0.0 and OpenOffice 2.2.1.

Relevant error in the alfresco.log file:
Caused by: javax.transaction.RollbackException: Transaction didn't commit: Content conversion failed:
   reader: ContentAccessor[ contentUrl=store://2007/8/2/12/9/6daabc6e-40e0-11dc-ae47-1d4adc75b92e.bin, mimetype=text/plain, size=17534, encoding=UTF-8, locale=en_US]
   writer: ContentAccessor[ contentUrl=store://2007/8/2/12/9/6dbc48a1-40e0-11dc-ae47-1d4adc75b92e.bin, mimetype=application/pdf, size=0, encoding=UTF-8, locale=en_US]

– Simon

Outcomes