AnsweredAssumed Answered

the result of 'FirstFoundationClient'

Question asked by mmrs on Nov 18, 2008
Latest reply on Nov 19, 2008 by mmrs
hi
finally i got no error when i run the FirstFoundationClient sample project   :mrgreen:
first i was using netbeans but i've replace it with eclips (less configuration required)  :P
i install:
- Alfresco-Labs-sdk-3a
- Alfresco-Labs-3b-Full
- MySql 5
- Eclips 3.4.1
- JDK 1.5.0_16
- Tomcat 6.0.14
- set up alfresco database(run the db_setup.bat file)
- add the jar file "alfresco-jlan-embed.jar" to the dir:"C:\alfresco-labs-sdk-3a\lib\server\" to be added to the AlfrescoEmbeded project library
- setting up the environment following the Instruction in the http://wiki.alfresco.com/wiki/Alfresco_SDK page
- copy the files "Win32NetBIOS.dll" , "Win32Utils.dll" and paste them to the "C:\WINDOWS\system32\"
- edit "custom-repository.properties" file in the FirstFoundationClient directory:

dir.root=C:/Alfresco/alf_data

#db.username=alfresco
#db.password=alfresco

#index.recovery.mode=FULL
# MySQL connection (This is default and requires mysql-connector-java-3.1.12-bin.jar, which ships with the Alfresco server)
#
#db.driver=org.gjt.mm.mysql.Driver
#db.url=jdbc:mysql://localhost/alfresco
- and reboot the computer
- running the project i got this result:


INFO  [config.xml.XMLConfigService$PropertyConfigurer] Loading properties file from class path resource [alfresco/file-servers.properties]
INFO  [domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
INFO  [domain.schema.SchemaBootstrap] No changes were made to the schema.
User:System WARN  [node.index.FullIndexRecoveryComponent] The indexes are not synchronized with the database.
User:System INFO  [repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: C:\Alfresco\alf_data
User:System INFO  [admin.patch.PatchExecuter] Checking for patches to apply …
User:System INFO  [admin.patch.PatchExecuter] No patches were required.
User:System INFO  [repo.module.ModuleServiceImpl] Found 0 module(s).
User:System WARN  [repo.module.ModuleServiceImpl] A previously-installed module 'org.alfresco.module.vti' (version 1.0) is not present in your distribution.
User:System WARN  [repo.module.ModuleServiceImpl] A previously-installed module 'org.alfresco.module.RecordsManagement' (version 1.3) is not present in your distribution.
User:System INFO  [service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_07-b06; maximum heap size 63.563MB
User:System WARN  [service.descriptor.DescriptorService] Alfresco JVM - WARNING - maximum heap size 63.563MB is less than recommended 512MB
User:System INFO  [service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (a 1032) schema 128 - Installed version 3.0.0 (b 1164) schema 131

does the project run correctly?
it should creates the "Company Home" folder,but i run the alfresco Web Client and find "no item to display" in My Home space !!  why ?  :roll:
thanx for help in advance .
((note: i run the alfresco server first)).

regards
mmrs

Outcomes