AnsweredAssumed Answered

2.1 CE, Tomcat 5.5, Cryptix error?

Question asked by cricalix on Aug 15, 2007
Latest reply on Sep 4, 2007 by andy
My Alfresco deployment has suddenly decided to bite me in the rear.  Last week, I was able to log in as admin/admin without issue (new installation).  I then played a bit with NTLM, but due to a conflict with Samba, never got far enough to actually authenticate.  Today, I backed out the extension changes for NTLM, and I'm getting CryptixCrypto errors when I try to log in.

Caused by: java.security.NoSuchAlgorithmException: class configured for MessageDigest(provider: CryptixCrypto)cannot be found.

locate -i cryptix
/usr/local/share/apache-tomcat-5.5.20/webapps/alfresco/WEB-INF/lib/cryptix-jce-provider.jar

Copied that jar to shared/lib as suggested in http://forums.alfresco.com/viewtopic.php?t=966 , but I can't reload Tomcat right now, it's a production server.

What boggles my mind is that Alfresco worked last week, and doesn't work this week.

Help?

Outcomes