AnsweredAssumed Answered

Auditing for ContentService (getReader) causes exception

Question asked by smolik on Nov 25, 2008
Latest reply on Dec 5, 2008 by breandanose
Hi all,
I have enabled the auditing for ContentService in auditConfig.xml file by this way:

<Service name="ContentService" mode="none">
        <Method name="getWriter" mode="all"/>
        <Method name="transform" mode="all"/>
        <Method name="getReader" mode="all"/>
</Service>

Everything worked, audit info is collected but when I try to download any content from Alfresco I've got the java exception:

org.alfresco.error.AlfrescoRuntimeException: Error during download content servlet processing: Read-Write transaction started within read-only transaction
caused by:
org.alfresco.error.AlfrescoRuntimeException: Read-Write transaction started within read-only transaction

This exception is for sure caused by auditing enable for getReader method. But I would like to know who downloaded particular file and thus this information is important for me.
Can anybody help me with this issue?

I am working on 3.0b Community Version.
I've found that there is exactly the same error reported for 2.2 Enterprise under bug      ETWOTWO-768.

Thank you very much,
Zdenek

Outcomes