AnsweredAssumed Answered

Alfresco 3.0 is not starting up in windows <solved>

Question asked by vijayakumar on Nov 25, 2008
Latest reply on Mar 5, 2009 by sachinj23
Hi,

I have installed Alfresco-Enterprise- 3.0.0-Full-Setup.exe in my windows XP machine. when I restarted my Alfresco server from c:/alfresco, my alfresco server not gets started and am getting the following response.

C:\Alfresco>virtual_start
starting virtual-tomcat
Starting Tomcat…
Using CATALINA_BASE:   c:\alfresco\virtual-tomcat
Using CATALINA_HOME:   c:\alfresco\virtual-tomcat
Using CATALINA_TMPDIR: c:\alfresco\virtual-tomcat\temp
Using JRE_HOME:        C:\Program Files\Java\jre1.5.0

C:\Alfresco>


Hence am manually starting tomcat and then virtual-tomcat  but my virtual-tomcat  was not sucessful and hence am unable to preview my files in the user sandbox. The log am getting is as follows:

Nov 25, 2008 5:49:36 PM org.springframework.context.support.AbstractApplicationContext prepareRefresh
INFO: Refreshing org.springframework.context.support.FileSystemXmlApplicationContext@186df0f: display name [org.springframework.context.support.FileSystemXmlApplicationContext@186df0f]; startup date [Tue Nov 25 17:49:36 GMT+05:30 2008]; root of context hierarchy
Nov 25, 2008 5:49:36 PM org.springframework.beans.factory.xml.XmlBeanDefinitionReader loadBeanDefinitions
INFO: Loading XML bean definitions from URL [file:C:/Alfresco/virtual-tomcat/conf/alfresco-virtserver-context.xml]
Nov 25, 2008 5:49:36 PM org.springframework.context.support.AbstractApplicationContext obtainFreshBeanFactory
INFO: Bean factory for application context [org.springframework.context.support.FileSystemXmlApplicationContext@186df0f]: org.springframework.beans.factory.support.DefaultListableBeanFactory@c44b88
Nov 25, 2008 5:49:36 PM org.springframework.core.io.support.PropertiesLoaderSupport loadProperties
INFO: Loading properties file from URL [file:C:/Alfresco/virtual-tomcat/conf/alfresco-shared.properties]
Nov 25, 2008 5:49:36 PM org.springframework.core.io.support.PropertiesLoaderSupport loadProperties
INFO: Loading properties file from URL [file:C:/Alfresco/virtual-tomcat/conf/alfresco-virtserver.properties]
Nov 25, 2008 5:49:36 PM org.springframework.beans.factory.support.DefaultListableBeanFactory preInstantiateSingletons
INFO: Pre-instantiating singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@c44b88: defining beans [virtserver-properties,avmReauthenticatingAdvisor,reauthenticatingAdvice,clientTicketHolder,authenticationService,avmRemote,avmRemoteTransport,avmRemoteTransportRaw,attributeService,attributeServiceTransport,attributeServiceTransportRaw,jndiInfoBean,virtServerInfo,virtServerMBeanServer,virtServerRegistry,serverConnector,virtServerExporter,virtWebappRegistry,cacheControlInfo]; root of factory hierarchy
Nov 25, 2008 5:50:36 PM org.springframework.beans.factory.support.DefaultSingletonBeanRegistry destroySingletons
INFO: Destroying singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@c44b88: defining beans [virtserver-properties,avmReauthenticatingAdvisor,reauthenticatingAdvice,clientTicketHolder,authenticationService,avmRemote,avmRemoteTransport,avmRemoteTransportRaw,attributeService,attributeServiceTransport,attributeServiceTransportRaw,jndiInfoBean,virtServerInfo,virtServerMBeanServer,virtServerRegistry,serverConnector,virtServerExporter,virtWebappRegistry,cacheControlInfo]; root of factory hierarchy
Nov 25, 2008 5:50:36 PM org.alfresco.catalina.host.AVMHost sleepBeforeRetryingConnection
WARNING: Retrying connection…

The above gets keep on repeating….
and finally am getting the error message as

Cjava.lang.ClassNotFoundException: org.apache.derby.impl.jdbc.EmbedSQL
Exception (no security manager: RMI class loader disabled)



In alfresco-virtserver.properties I have changed the content as follows:

alfresco.virtserver.domain=172-20-56-113.ip.alfrescodemo.net

where 172-20-56-113 is my IP (i.e. localhost) address…


I also tried to change the following in alfresco-shared.properties

from
alfresco.rmi.services.port=50500
to
alfresco.rmi.services.port=8180

Please help me in this regard

Outcomes