AnsweredAssumed Answered

Starting OpenOffice headless as user alfresco

Question asked by frankg on Dec 2, 2008
Latest reply on Dec 16, 2008 by yyovkov
Hello,

I would like to start OpenOffice 2.4 as user "alfresco". I am using the command:

sudo -H -u alfresco /opt/openoffice.org2.4/program/soffice -headless "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" -nofirststartwizard &

This is the output:

[1] 16819
[root@alfresco program]# Xlib: connection to ":1003.0" refused by server
Xlib: No protocol specified

/opt/openoffice.org2.4/program/soffice.bin X11 error: Can't open display: :1003.0
   Set DISPLAY environment variable, use -display option
   or check permissions of your X-Server
   (See "man X" resp. "man xhost" for details)

When I simply execute this command as root

opt/openoffice.org2.4/program/soffice -headless "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" -nofirststartwizard &


soffice starts headless in the background and i do not get any error messages in the alfresco.log and soffice is listening on port 8100 as i want it to.


Why can't user alfresco execute start soffice? I can't find any hints..
I already installed a newer version of Open Office than the one shipped with CentOS, cause I've red that CentOS' oo. can cause problems. Actually with the newer version oo. headless works for me.

Thank you very much in advance

Outcomes