AnsweredAssumed Answered

Opera Browser can't render XForms

Question asked by d.segato on Dec 3, 2008
Latest reply on Dec 3, 2008 by d.segato
It's only me or Alfresco WCM doesn't work on Opera Browser?
I get this error after clicking "next" on the "company-footer" (example xsd) webform creation:

JavaScript
Event thread: BeforeScript
Opera has modified the JavaScript on localhost (legacy TinyMCE enter fix + link button fix). See browser.js for details
JavaScript - http://localhost:8080/alfresco/faces/jsp/wizard/container.jsp
Timeout thread: delay 10 ms
Error:
name: TypeError
message: Statement on line 371: Cannot convert undefined or null to Object
Backtrace:
  Line 371 of linked script http://localhost:8080/alfresco/scripts/ajax/xforms.js
                       var s = binding.nodeset;
  Line 337 of linked script http://localhost:8080/alfresco/scripts/ajax/xforms.js
                     var xpath = this._getXPathInInstanceDocument();
  Line 603 of linked script http://localhost:8080/alfresco/scripts/ajax/xforms.js
                     var initial_value = this.getInitialValue() || "";
  Line 2653 of linked script http://localhost:8080/alfresco/scripts/ajax/xforms.js
                     child.render(contentDiv);
  Line 2381 of linked script http://localhost:8080/alfresco/scripts/ajax/xforms.js
                     return this._insertChildAt(child, this._children.length);
  Line 4162 of linked script http://localhost:8080/alfresco/scripts/ajax/xforms.js
                         parentWidget.addChild(w);
  Line 4080 of linked script http://localhost:8080/alfresco/scripts/ajax/xforms.js
                     this.loadWidgets(rootGroup, this.rootWidget);
  Line 4053 of linked script http://localhost:8080/alfresco/scripts/ajax/xforms.js
                                                                 this.target._loadHandler(data);
  Line 67 of linked script http://localhost:8080/alfresco/scripts/ajax/ajax_helper.js
    function() { result._baseLoadHandler(type, data, event, kwArgs); }
  …
stacktrace: n/a; see 'opera:config#UserPrefs|Exceptions Have Stacktrace'

and the Forms is not loaded at all

(and there are many CSS error/warning in all pages)

Outcomes