AnsweredAssumed Answered

No transforms are working after successful install

Question asked by pepperking on Aug 26, 2007
Latest reply on Aug 28, 2007 by mohrmann
we are currently running the lastest version 2.1 with MYSQL.  Nearly all other aspects of the install are working fine including ldap and passthru authentication and have sucessfully added custom spaces.  However when ever we create any rules to transform files from one mimetype to another we get the following error below in the log and an error on the front end which says:

A system error happened during the operation: Unknown Exception in Transaction


We have tried nearly every combination of different items to transform to each with the same result.  This is via the web interface and/or CIFS. Am stumped without a solution for this.

Caused by: javax.transaction.RollbackException: Transaction didn't commit: No transformation exists between mimetypes application/msword and text/html
   at org.alfresco.util.transaction.SpringAwareUserTransaction.commit(SpringAwareUserTransaction.java:430)
   at org.alfresco.repo.transaction.RetryingTransactionHelper.doInTransaction(RetryingTransactionHelper.java:239)
   … 32 more
Caused by: org.alfresco.service.cmr.repository.NoTransformerException: No transformation exists between mimetypes application/msword and text/html
   at org.alfresco.repo.action.executer.TransformActionExecuter.executeImpl(TransformActionExecuter.java:189)

Outcomes