AnsweredAssumed Answered

derby DB upgrade

Question asked by hreintke on Dec 20, 2008
Latest reply on Dec 24, 2008 by hreintke
LS,

I am running the default Derby database for version 3b and want to upgrade to 3c.
When starting a "automatic upgrade" I do get errors stating that the right upgrade scripts cannot be found.

Can you tell me which upgrade scripts are supposed to be run ?

Looking in the dbscripts/upgrade directory I have directories for 1.3, 1.4, 2.0, 2.1 and 2.2.

From the earlier posts I expect that the 2.2 scripts are the right one ??
In the 2.2 directory I have
org.hibernate.dialect.Dialect
org.hibernate.dialect.MysqlInnodbdialect
org.hibernate.dialect.Oracle9Dialect

Questions:

Are the scripts in ..Dialect the ones for the Derby DB ?
How does Alfresco select the scripts to run ?
Can I run the scripts manually to upgrade ?

Kind regards,

Herman

Outcomes