AnsweredAssumed Answered

Problems using Templates in WCM

Question asked by marcus_cps on Sep 11, 2007
Latest reply on Sep 18, 2007 by marcus_cps
Hi,

I´m trying create a content based on a template, but I´m having trouble with classes needed.

I´ve installed Alfresco and WCM (it worked fine).
(uncompressed, set to MySQL and moved bootstrap to the right location).
After that, I got a template from the website (thumbs.ftl) and put it in /shared/templates folder (virtual-apache).
Added html_basic.tld and repo.tld to a new project (tld folder) and to tle tld folder at virtual-tomcat/shared.
I added main.jsp to the project:

– main.jsp:
<%@ taglib uri="/tld/html_basic.tld" prefix="h" %>
<%@ taglib uri="/tld/repo.tld" prefix="r" %>

<html>
<body>

<f:view>
   <h:form>
     <r:template template="/shared/templates/thumbs.ftl" />
   </h:form>
</f:view>

</body>
</html>

But when I try to preview it, a lot of error occur.
I´ve tryed to add a lot of .class files to the shared/classes folder of virtual-tomcat but it still not working. Everytime it complains about something, I grab it from javax or servlet lib and put it there.
Is there something wrong? I cant even imagine what else to do.

Thank you very much.

Outcomes