AnsweredAssumed Answered

Requesting help in setting up the Alfresco component

Question asked by xstatik on Dec 30, 2008
Latest reply on Dec 26, 2009 by phirschorn
Hello,

I tried to install the new Alfresco component on my Joomla 1.5 testing website.  I am running Alfresco 3c which works great on its own.  I installed and configured the component and added an Alfresco link to my main menu.  However, when I click the link, I receive the following error message:

Fatal error: Uncaught exception 'Zend_Uri_Exception' with message 'Illegal scheme supplied, only alphanumeric characters are permitted' in /mysite/administrator/components/com_alfresco/libraries/Zend/Uri.php:98 Stack trace: #0
/mysite/administrator/components/com_alfresco/libraries/Zend/Http/Client.php(223): Zend_Uri::factory('/service/api/lo…') #1
/mysite/administrator/components/com_alfresco/libraries/Zend/Http/Client.php(209): Zend_Http_Client->setUri('/service/api/lo…') #2
/mysite/components/com_alfresco/models/abstract.php(159): Zend_Http_Client->__construct('/service/api/lo…', Array) #3 /mysite/components/com_alfresco/models/abstract.php(216): AlfrescoModelAbstract->getXml('/service/api/lo…') #4 /mysite2/components/com_alfresco/models/abstract.php(62): AlfrescoModelAbstract->authenticate() #5 /mysite2/libraries/joomla/application/component/model.php(129): AlfrescoModelAbstract->_ in /mysite/administrator/components/com_alfresco/libraries/Zend/Uri.php on line 98

The component is configured as follows:

Name: Test Alfresco Repository
Server:  http://sitename:8080/alfresco
Share:  http://sitename:8080/share
I'm using a regular Alfresco user (not an admin) for the username/password fields.
Published: Yes

If anyone has any suggestions on getting the component up and running, I'd greatly appreciate the help.

Outcomes