AnsweredAssumed Answered

FreeBSD 6.3  and Tomcat 6.0.14 - still not working for me

Question asked by m.r. on Jan 2, 2009
Latest reply on Jan 19, 2009 by m.r.
After unpacking alfresco-labs-war-3c.tar.gz and editing 
custom-hibernate-dialect.properties
file-servers-custom.xml
custom-repository.properties
to work with PostgreSQL  (and editing out the Windows LF/CR's)

17:56:27,288  INFO  [web.scripts.AbstractRuntimeContainer] Initialised Presentation Web Script Container (in 440.762ms)
17:56:27,296  ERROR [web.context.ContextLoader] Context initialization failed
org.springframework.beans.factory.CannotLoadBeanClassException: Cannot find class [org.alfresco.web.scripts.DeclarativeSiteWizardWebScript] for bean with name 'webscript.wizard' defined in class path resource [alfresco/web-framework-application-context.xml]; nested exception is java.lang.ClassNotFoundException: org.alfresco.web.scripts.DeclarativeSiteWizardWebScript
Caused by: java.lang.ClassNotFoundException: org.alfresco.web.scripts.DeclarativeSiteWizardWebScript
        at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1387)


vi WEB-INF/classes/alfresco/web-framework-application-context.xml

^M
   <!–  Dynamic Wizard Web Script –>^M
   <bean id="webscript.wizard" parent="webscript" class="org.alfresco.web.script
s.DeclarativeSiteWizardWebScript" singleton="false" />^M
^M
^M


I am trying to have Alfresco work before I start teaching the Advance Linux class at the local community college.   If I can't get Alfresco working it won't be part of my class.

Outcomes