AnsweredAssumed Answered

Module Management Tool Version Problem

Question asked by hanspoi on Sep 19, 2007
Hi,

by trying to install the e-mail listener (RC2) the apply_amps batchfile comes up with this message from below.

I run Alfresco 2.1 on XP Pro and have a alfresco-mmt-jar located in the bin subdirectory.

Kind regards,
Hans
————–

D:\Programme\alfresco>apply_amps
This script will apply all the AMPs in D:\Programme\alfresco\amps to the alfresc
o.war file in D:\Programme\alfresco\tomcat\webapps
Press control-c to stop this script . . .
Drücken Sie eine beliebige Taste . . .
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/alfresco/
repo/module/tool/ModuleManagementTool (Unsupported major.minor version 49.0)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
        at com.simontuffs.onejar.JarClassLoader.defineClass(JarClassLoader.java:
450)
        at com.simontuffs.onejar.JarClassLoader.findClass(JarClassLoader.java:44
1)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
        at com.simontuffs.onejar.Boot.run(Boot.java:245)
        at com.simontuffs.onejar.Boot.main(Boot.java:105)
Drücken Sie eine beliebige Taste . . .
Cleaning temporary Alfresco files from Tomcat…

Outcomes