AnsweredAssumed Answered

Problem with alfreco labs installation

Question asked by bodhayanm on Jan 12, 2009
Latest reply on Jan 13, 2009 by punit.oza
Hi,

I had alfresco enterprise 3.0 trial version (Alfresco-Enterprise-3.0.0-Full-Setup.exe) installed for some PoC purpose. Then I installed alfresco labs (Alfresco-Labs-3c-Full-Setup.exe) without un-installing the earlier enterprise version. Now when I tried to run alfresco server for the labs installation (enterprise version was not running at that time) I got the following exception:

13:01:00,662  ERROR [web.context.ContextLoader] Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.springframework.remoting.rmi
.RmiServiceExporter' defined in class path resource [alfresco/emailserver/email-service-context.xml]: Invocation of init
method failed; nested exception is java.rmi.server.ExportException: internal error: ObjID already in use
Caused by: java.rmi.server.ExportException: internal error: ObjID already in use


I tried changing the port number for the email server from 25 in file "D:\Alfresco\tomcat\webapps\alfresco\WEB-INF\classes\alfresco\emailserver\email-server.properties" but it is still not working. I did some googling and it seems that the problem is with the RMI registry, but I am stuck at that.

Can anybody please help me how to resolve this issue.

Btw, I have also tried uninstalling enterprise version and then uninstalling labs version and re-installing labs version. But same problem still persists.

– Bodh

Outcomes