AnsweredAssumed Answered

Web Studio - Failed to load script

Question asked by sbarcena on Jan 27, 2009
Latest reply on Jul 15, 2010 by pp20218
Hello to all,

It is not possible to create a new web site because there is not loaded the list that should appear under the text " Based on the following: ".
In the console of the tomcat the following thing appears:

[web.scripts.AbstractRuntime] Caught exception & redirecting
to status template: Failed to load script '/web-studio/api/prebuilt/list.get.js
(in classpath store file:C:/Alfresco/tomcat/webapps/studio/WEB-INF/classes/alfr
esco/webscripts)': TypeError: Cannot read property "results" from null (file:C:/
Alfresco/tomcat/webapps/studio/WEB-INF/classes/alfresco/webscripts/web-studio/ap
i/prebuilt/list.get.js#47)


I have Internet gone out across proxy.

I have removed the commentary of the block:

<config evaluator="string-compare" condition="Server">
      <server>
         <!– Enable and adjust the following settings to allow for external access URLs to the
              WebScript Framework - to return an externally accessable address for absolute url generation.
         <scheme>http</scheme>
         <hostname>localhost</hostname>
         <port>8080</port>
         <path>alfresco</path>
         –>
      </server>
   </config>


of the following files:

alfresco/tomcat/webapps/alfresco/webscript-framework-config.xml
alfresco/tomcat/webapps/share/webscript-framework-config.xml
alfresco/tomcat/webapps/studio/webscript-framework-config.xml


but that isn't work.

Must I add in these files an endpoint relative to the alfresco-network that is formed in the file web - framework-config-application.xml?

Any idea?

PD: excuse me for my english  :cry:

Outcomes