AnsweredAssumed Answered

[SOLVED]Axis Problems with Alfresco SDK

Question asked by sisao on Feb 6, 2009
Latest reply on Mar 12, 2009 by rv.a.sharma
Hi guys,

i'm having a weird problem while running the SDK WebServices samples using Eclipse (well the problem started with my app but i use the samples provided with the SDK just to be sure…), dont know if this is the proper forum space though.
I run the ContentReadAndWrite.java that should put some content in my Company Home folder, and so it used to do.

Enviroment:
Leopard OsX latest
JVM 1.5
Eclispe Ganymede
Alfresco 3 labs stable with Tomcat embedded on port 8088 (Apache Tomcat Runinng on port 8080 with Axis2 webapp deployed and working)
ALfresco SDK 3 latest

What i can remember to have done BEFORE the problem was to update axis to version 2 release 1.4 using a war.
I've removed axis plugin in the eclipse/plugins folder just to be sure…

With the same setup and tools the samples run with no errors into a different machine…so something is wrong in my classpath, i do not use the CLASSPATH env variable, i just use eclipse.

With the JVM 1.5 this is the error i get:

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/axis/description/FieldDesc
   at org.alfresco.sample.webservice.SamplesBase.<clinit>(SamplesBase.java:50)

Referenced Libs = axis-1.4.jar ; axis-ant.jar
System Libs = standard JVM 1.5 + JCR +  alfresco-web-client*.jar

Any tips guys?? I guess that's a runtime problem but i cannot really solve it atm and i need to use the alfresco WS API.

Regards.

Outcomes