AnsweredAssumed Answered

JBoss 4.2.1GA and Share and Login Issues

Question asked by rd341p on Feb 14, 2009
Latest reply on Feb 17, 2009 by edk
Hello to everyone,
Its been a uphill task for me deploying alfresco 3.0c under Jboss 4.2.1GA. After reading the wiki for installing alfresco under jboss and going through many forums and posting, I was finally able to deploy alfresco 3.0c + WCM under Jboss 4.2.1GA. Now one thing that has still not worked for me, is the share application.

First let me briefly put in what the setup is and how I deployed alfresco.
OS: Fedora Linux
Java: java version "1.6.0_12-ea"
Jboss: 4.2.1GA
MySQL: 5.0.27
MySQL connector: mysql-connector-java-5.1.5

I deployed Jboss4.2.1 GA and then followed up with the wiki. Deploying alfresco.war under jboss/server/default/deploy/, put in the mysql connection in jboss/server/default/lib/  and made the necessary changed to the *.repositories. Started jboss and alfresco came up fine. Hurray, I could login and play around.

Now, I wanted share too.. so I copied share.war under jboss/server/default/deploy/ and restarted jboss.   :( but the logs started displaying errors
org.apache.catalina.core.StandardContext listenerStart
SEVERE: Exception sending context initialized event to listener instance of clas
s org.apache.myfaces.webapp.StartupServletContextListener
java.lang.NoClassDefFoundError: org/apache/commons/el/Logger

It looks like commons-el is missing. Went to  http://commons.apache.org/downloads/download_el.cgi, downloaded the file and copied commons-el.jar to jboss/server/default/lib/ .  Also from quite a few postings I found that I had to add  Java opt flag, -Dorg.apache.catalina.STRICT_SERVLET_COMPLIANCE=false in jboss/bin/run.conf

 JAVA_OPTS="$JAVA_OPTS -Dorg.apache.catalina.STRICT_SERVLET_COMPLIANCE=false"
.

Restarted jboss and now I could see http://<ip>:8080/share with the login screen. But when I tried to supply the credentials admin/<somepass>, Failed to Login. This is the same login, I used to access Alfresco (where is works perfectly). There were no exceptions in the logs too…..

What am I missing or what am I doing wrong ???

Can anyone please help me…

Thank you

Outcomes