AnsweredAssumed Answered

Cannot Edit Files Online (Alfresco 3 Stable - Mac OS X)

Question asked by hordak1223 on Feb 16, 2009
Latest reply on Feb 26, 2009 by hordak1223
Hello (& Thanks in Advance  :D ),

My Problem: 

I've successfully installed Alf_Stable3 along with support (ImageMagick, swftools, Openoffice).  I'm seeing no Major error messages:

13:54:10,272 INFO  [org.alfresco.config.xml.XMLConfigService$PropertyConfigurer] Loading properties file from class path resource [alfresco/file-servers.properties]
13:54:37,536 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
13:54:37,703 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Executing database script /opt/alfresco/tomcat/temp/Alfresco/AlfrescoSchemaCreate-org.hibernate.dialect.MySQLInnoDBDialect-19747.sql (Generated).
13:54:41,390 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Executing database script /opt/alfresco/tomcat/temp/Alfresco/AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-19748.sql (Copied from classpath:alfresco/dbscripts/create/2.2/org.hibernate.dialect.MySQLInnoDBDialect/AlfrescoPostCreate-2.2-MappedFKIndexes.sql).
13:54:41,400 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Executing database script /opt/alfresco/tomcat/temp/Alfresco/AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-19749.sql (Copied from classpath:alfresco/dbscripts/create/2.2/org.hibernate.dialect.MySQLInnoDBDialect/AlfrescoPostCreate-2.2-Extra.sql).
13:54:41,847 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Executing database script /opt/alfresco/tomcat/temp/Alfresco/AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-19750.sql (Copied from classpath:alfresco/dbscripts/create/2.2/org.hibernate.dialect.MySQLInnoDBDialect/post-create-indexes-04.sql).
13:54:41,870 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Executing database script /opt/alfresco/tomcat/temp/Alfresco/AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-19751.sql (Copied from classpath:alfresco/dbscripts/create/3.0/org.hibernate.dialect.MySQLInnoDBDialect/create-activities-extras.sql).
13:54:42,011 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] All executed statements written to file /opt/alfresco/tomcat/temp/Alfresco/AlfrescoSchemaUpdate-All_Statements-19752.sql.
13:55:43,810 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: /opt/alfresco/alf_data
13:55:43,910 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
13:55:48,059 INFO  [org.alfresco.repo.admin.patch.PatchExecuter]    Applying patch 'patch.wcmFolders' (Ensures the existance of the WCM specific 'Web Projects' and 'Web Forms' folders.).
13:55:48,426 INFO  [org.alfresco.repo.admin.patch.PatchExecuter]
=== Applied patch                 ===
ID: patch.db-V3.0-0-CreateActivitiesExtras
RESULT:
Script completed
=====================================
13:55:48,428 INFO  [org.alfresco.repo.admin.patch.PatchExecuter]
=== Applied patch                 ===
ID: patch.wcmFolders
RESULT:
The Web Projects folder was successfully created: workspace://SpacesStore/aa894396-378c-4b49-8d31-3eadf4bcae79
The Web Forms folder was successfully created: workspace://SpacesStore/aa894396-378c-4b49-8d31-3eadf4bcae79
=====================================
13:55:48,472 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 2 module(s).
13:55:48,640 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Installing module 'org.alfresco.module.vti' version 1.0.
13:55:48,835 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Installing module 'org.alfresco.module.RecordsManagement' version 1.3.
13:56:14,784 ERROR [org.alfresco.smb.protocol] Failed to get local domain/workgroup name, using default of WORKGROUP
13:56:14,784 ERROR [org.alfresco.smb.protocol] (This may be due to firewall settings or incorrect <broadcast> setting)
13:56:15,782 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.5.0_13-b05-237; maximum heap size 506.313MB
13:56:15,783 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (Stable 1526) schema 1002 - Installed version 3.0.0 (Stable 1526) schema 1002
13:57:01,913 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
13:57:12,958 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 67 Web Scripts (+0 failed), 71 URLs
13:57:12,963 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised Presentation Web Script Container (in 983.213ms)
13:58:14,876 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 101 Web Scripts (+0 failed), 105 URLs
13:58:14,876 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised WebFramework Web Script Container (in 61873.918ms)
13:58:15,049 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
I am working within the Share environment's Document Library.  HERE is where the problem arrises.  I cannot preview documents and I cannot Edit online any Documents (.doc, .odt, .txt, .rtf or .pdf).  From what I've read so far, I'm supposed to be able to do this.  I have updated the vti module per other posts as well.  Could there be a Root user issue?  I've installed under root user permissions?

What am I doing wrong?

Outcomes