AnsweredAssumed Answered

'Couldn't find bootstrap model' error - Everything

Question asked by bfontana on Nov 12, 2007
Latest reply on Nov 12, 2007 by bfontana
Hi everybody,
I'm trying to deploy a custom jBPM workflow following the guides found in documentation and in this forum but when I started JBOSS the following exception is thrown

Caused by: org.alfresco.service.cmr.dictionary.DictionaryException: Could not find bootstrap model
               contratos_model.xml
            
   at org.alfresco.repo.dictionary.DictionaryBootstrap.bootstrap(DictionaryBootstrap.java:99)
   at org.alfresco.repo.workflow.WorkflowDeployer.deploy(WorkflowDeployer.java:188)
   … 143 more

This is my …-context.xml configuration file.




<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>

   <bean id="lifecycle.workflowBootstrap" parent="workflowDeployer">
      <property name="workflowDefinitions">
         <list>
            <props>
               <prop key="engineId">jbpm</prop>
               <prop key="location">
                  alfresco/extension/contratos/contratos_processdefinition.xml
               </prop>
               <prop key="mimetype">text/xml</prop>
               <prop key="redeploy">false</prop>
            </props>
         </list>
      </property>
      <property name="labels">
         <list>
            <value>
               alfresco/extension/contratos/contratos-messages
            </value>
         </list>
      </property>
      <property name="models">
         <list>
            <value>
               alfresco/extension/contratos/contratos_model.xml
            </value>
         </list>
      </property>
   </bean>
      <bean id="webClientConfigSource"
      class="org.alfresco.config.source.UrlConfigSource">
      <constructor-arg>
         <list>
            <value>classpath:alfresco/web-client-config.xml</value>
            <value>
               classpath:alfresco/web-client-config-dialogs.xml
            </value>
            <value>
               classpath:alfresco/web-client-config-wizards.xml
            </value>
            <value>
               classpath:alfresco/web-client-config-properties.xml
            </value>
            <value>
               classpath:alfresco/web-client-config-navigation.xml
            </value>
            <value>
               classpath:alfresco/web-client-config-wcm.xml
            </value>
            <value>
               classpath:alfresco/web-client-config-actions.xml
            </value>
            <value>
               classpath:alfresco/web-client-config-forum-actions.xml
            </value>
            <value>
               classpath:alfresco/web-client-config-wcm-actions.xml
            </value>
            <value>
               classpath:alfresco/web-client-config-workflow-actions.xml
            </value>
            <value>
               classpath:web-client-demo-config.xml
            </value>
         </list>
      </constructor-arg>
   </bean>
</beans>

This file is under …/jbossXXX/server/default/deploy/alfresco.war/WEB-INF/classes with alfresco.war being the directory where alfresco WAR file is decompressed.
I've tried everything from this to defining a custom CLASSPATH entry and putting the files in there (and changing the context file of course) but anything of this worked.

Any help would be appreciated.
Thanks in advance

Bruno

Outcomes