AnsweredAssumed Answered

Alfresco 2.1 + Oracle10g fail on start (2.0 & oracle wor

Question asked by lfuller on Nov 27, 2007
Latest reply on Dec 12, 2007 by lfuller
Am not new to alfresco, we have an alfresco 2.0 instance up and running on oracle with little to no difficulties.  So we decided to upgrade to 2.1 (mostly because the clustering in 2.0 did not function properly).  Unfortunately, after modifying the configs and attempting a start I ran into this error:
11:14:23,139 WARN  [remoting.rmi.RmiRegistryFactoryBean] Could not detect RMI registry - creating new one
11:14:24,912 WARN  [alfresco.util.OpenOfficeConnectionTester] A connection to OpenOffice could not be established.
11:14:28,256 INFO  [domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.Oracle9Dialect.
11:14:30,735 ERROR [domain.schema.SchemaBootstrap] Schema auto-update failed
java.sql.SQLException: ORA-00942: table or view does not exist

So, after a good deal of frustrution I eventually pulled down alfresco-community-tomcat-2.1.0.tar.gz and set it up with a clean db and a clean alf_data directory.  Then I configured it following these instructions:
http://wiki.alfresco.com/wiki/Database_Configuration
I slid the same oracle jdbc driver jar that was functioning with 2.0 into \tomcat\common\lib I also made certain that the same connection information that was/is functioning with 2.0 was also placed in the appropriate properties file.
I also added the dbpool config file custom-connection-pool-context.xml and made certain the validationQuery was correct.

However I get the exact same error.  After digging through the forums I see others have also had difficulty with running Allfresco 2.1 with Oracle, but have not seen anyone claiming to have successfully have run this combination much less post anything concerning how they did it.

I'm not new to alfresco, nor am I new to java or configuring java apps.  There has to be something I am missing here:)  Has anyone actually gotten Alfresco 2.1 community to run with Oracle?  If so, a little help would be appreciated.

——————–custom-connection-pool-context.xm—————————————
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<!–
   An example of how to override the dataSource bean.
   If an alternative pool is desired, such as C3P0, then it can be referenced by   changing the 'class' attribute and adding or removing the required properties.
   The required libraries can be dropped into the servers extension lib folders.–>
<beans>

    <!– DBCP Configuration –>
    <!– http://jakarta.apache.org/commons/dbcp/configuration.html –>
    <bean id="dataSource" class="org.apache.commons.dbcp.BasicDataSource" destroy-method="close">
        <!– connection settings –>
        <property name="driverClassName">
            <value>${db.driver}</value>
        </property>
        <property name="url">
            <value>${db.url}</value>
        </property>
        <property name="username">
            <value>${db.username}</value>
        </property>
        <property name="password">
            <value>${db.password}</value>
        </property>
        <property name="defaultAutoCommit" >
            <value>false</value>
        </property>
        <!– pool settings –>
        <property name="minIdle" >
            <value>${db.pool.initial}</value>
        </property>
        <property name="maxActive" >
            <value>${db.pool.max}</value>
        </property>
        <property name="maxWait" >
            <value>10000</value>
        </property>
        <property name="validationQuery" >
            <value>select 1 from dual</value>
        </property>
        <property name="timeBetweenEvictionRunsMillis" >
            <value>300000</value>
        </property>
        <property name="minEvictableIdleTimeMillis" >
            <value>60000</value>
        </property>
        <property name="testOnBorrow" >
            <value>false</value>
        </property>
        <property name="testOnReturn" >
            <value>false</value>
        </property>
        <property name="testWhileIdle" >
            <value>true</value>
        </property>
        <property name="removeAbandoned" >
            <value>true</value>
        </property>
        <property name="removeAbandonedTimeout" >
            <value>30</value>
        </property>
    </bean>
          
</beans>
——————————-

Outcomes