AnsweredAssumed Answered

Installing Alfresco 3 on Websphere 6.1

Question asked by jgould on Feb 27, 2009
Latest reply on May 29, 2009 by jgould
Hi, I have recently been looking to deploy Alfresco Labs 3 to WebSphere 6.1.

Deploying the WAR, setting up the class path, and the JDDB driver were relatively trivial tasks, however when the application ran (with no errors in the logs), I have an issue whereby the pages are all corrupted (blank panels). I assumed this was due to the faces plugin, and by turing up the logs to debug on the myfaces classes I could see that there was a issue with the faces resolving the path to each individual panel in the page:

[org.apache.myfaces.el.VariableResolverImpl] Variable 'xxxxx' could not be resolved

Reading up on this issue, I found some guides suggesting that I would need to follow (for Alfresco 2.1) http://wiki.alfresco.com/wiki/Installing_on_WebSphere
However implementing the advised changes for 6.1 ended up in the same issue. With the following log advising that both "MyFaces and RI implementations of JSF have been found on the classpath".

Other docs I came accross suggested that I switch the Application class loaded to load the app classes before the parent classes, having tried this it has always led to a Java error on start up, depending upon the lib set up it was either related to

"WebSphere issue java.lang.ClassCastException: org.apache.xerces.jaxp.DocumentBuilderFactoryImpl incompatible with javax.xml.parsers.DocumentBuilderFactory" <– one document (http://cwiki.apache.org/confluence/display/CXF20DOC/AppServerGuide#AppServerGuide-Websphere) suggested I needed to copy a jar file to my java endorsed folder, I tried this, and tried putting in into the common lib & the app lib, always with the same error.

The other issue I came accross was:
"Error Message: Error creating bean with name 'org.apache.cxf.wsdl.WSDLManager' defined in class path resource [META-INF/cxf/cxf.xml]: Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [org.apache.cxf.wsdl11.WSDLManagerImpl]:"

I would be very interested in hearing from anybody who has had more luck than myself deploying Alfresco Labs 3 to Websphere 6.1, or managed to correct any of these issues,

Regards,

James

Outcomes