AnsweredAssumed Answered

HELP REQ.: JCR-RMI Alfresco 2.1.0 JBoss 4.0.5 configuration

Question asked by sunfriend on Nov 28, 2007
Latest reply on Nov 28, 2007 by sunfriend
Hi all!.

I'm trying to start the alfresco jcr-rmi bridge.
I've placed the:
jackrabbit-jcr-rmi-1.3.3.jar
extension-jcr-thread-bound.jar
extension-jcr-rmi.jar

inside the web-inf/lib (alfresco's war commonity edition)

The conf looks like:

jcr-rmi.context.xml

    <import resource="classpath:alfresco/jcr-context.xml" />
  
    <!– load common properties –>
    <bean id="jcr-rmi-properties" class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer">
      <property name="ignoreUnresolvablePlaceholders">
        <value>true</value>
      </property>
   
      <property name="locations">
        <list>
          <value>classpath:alfresco/extension/jcr-rmi.properties</value>
        </list>
      </property>
    </bean>
   
    <!– /////////////////////////////////// –>
    <!–                                     –>
    <!–  rmi java content repository        –>
    <!–                                     –>
    <!– /////////////////////////////////// –>
    <bean id="javaContentRepositoryRmiBinding"
          class="org.alfresco.jcr.repository.JcrRmiBindingUtil"
          init-method="bind">

<!–        <ref bean="JCR.Repository"/> –>
      <property name="jcrRepository">
        <ref bean="threadBoundJcrRepository"/>
      </property>

jcr-rmi.properties

# ##################### #
# RMI JCR Configuration #
# ##################### #

rmi.jcr.binding.servername=localhost
#rmi.jcr.binding.port=1099
rmi.jcr.binding.port=50500
rmi.jcr.binding.name=javaContentRepository
rmi.jcr.resources.path=/alfresco/extension/messages/jcr-rmi-messages.properties

and thread-bound-jcr-context.xml:

<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>
  
 
   
    <!– /////////////////////////////////////// –>
    <!–                                         –>
    <!–  thread bound java content repository   –>
    <!–                                         –>
    <!– /////////////////////////////////////// –>
    <bean id="threadBoundJcrRepository"
          class="org.alfresco.jcr.repository.ThreadBoundJcrRepositoryImpl">

      <property name="backingJcrRepository">
        <ref bean="JCR.Repository"/>
      </property>
    </bean>
</beans>

I try to start the server and gets crazy reloading configuration until stack overflow is reached.

I need it working… snif!.

Any help would be appreciated,
cheers,
sunfriend.

Outcomes