AnsweredAssumed Answered

[SOLVED] Share returns an error when loggin in

Question asked by showky on Mar 3, 2009
Hi,
I've installed Alfresco 3 Stable, and it's running perfectly for 2 weeks. I hadn't try "share" since the install, and I decided to test it today…But apparently there is an error :(

When I access :
http://localhost:8080/alfresco
everything works fine.

but when I try :
http://localhost:8080/share
the page loads, asks me to login. I log under "admin", and then it sends me a 404 error ! Here comes the logs files…

catalina.log :

3 mars 2009 12:10:44 org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initialisation de Coyote HTTP/1.1 sur http-8080
3 mars 2009 12:10:44 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 609 ms
3 mars 2009 12:10:44 org.apache.catalina.core.StandardService start
INFO: Démarrage du service Catalina
3 mars 2009 12:10:44 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.23
3 mars 2009 12:10:44 org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
3 mars 2009 12:10:45 org.apache.catalina.startup.HostConfig deployWAR
INFO: Déploiement de l'archive alfresco.war de l'application web
3 mars 2009 12:11:42 org.apache.catalina.startup.HostConfig deployWAR
INFO: Déploiement de l'archive share.war de l'application web
3 mars 2009 12:11:45 org.apache.catalina.startup.HostConfig deployWAR
INFO: Déploiement de l'archive studio.war de l'application web
3 mars 2009 12:12:20 org.apache.coyote.http11.Http11BaseProtocol start
INFO: Démarrage de Coyote HTTP/1.1 sur http-8080
3 mars 2009 12:12:20 org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
3 mars 2009 12:12:20 org.apache.catalina.startup.Catalina start
INFO: Server startup in 96000 ms
Everything seams ok for me ?

alfresco.log :

12:11:05,531 INFO  [org.alfresco.config.xml.XMLConfigService$PropertyConfigurer] Loading properties file from class path resource [alfresco/file-servers.properties]
12:11:18,125 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
12:11:21,734 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Aucune modification na été apportée au schéma.
12:11:25,406 INFO  [org.alfresco.repo.admin.ConfigurationChecker] Le répertoire racine de données d'Alfresco ('dir.root') est : C:\Alfresco\alf_data
12:11:25,453 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Vérification des correctifs à appliquer …
12:11:25,671 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Aucun correctif requis.
12:11:25,687 INFO  [org.alfresco.repo.module.ModuleServiceImpl] 2 module(s) trouvé(s).
12:11:25,750 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Démarrage du module 'org.alfresco.module.RecordsManagement' version 1.3.
12:11:25,890 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Démarrage du module 'org.alfresco.module.vti' version 1.0.
12:11:26,921 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_11-b03; maximum heap size 986,125MB
12:11:26,921 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (c 1342) schema 1000 - Installed version 3.0.0 (c 1342) schema 1000
12:11:27,156 WARN  [org.alfresco.linkvalidation.LinkValidationServiceImpl] LinkValidationService Update is not running (virtualization server not registered or started)
12:11:45,468 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 21 Web Scripts (+0 failed), 23 URLs
12:11:45,468 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised Presentation Web Script Container (in 241.96172ms)
12:11:45,625 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 21 Web Scripts (+0 failed), 23 URLs
12:11:45,625 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised WebFramework Web Script Container (in 148.84335ms)
12:11:45,750 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
12:12:19,953 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
12:12:49,875 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/header does not map to a Web Script.
12:12:49,953 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/title/user-dashboard-title does not map to a Web Script.
12:12:49,968 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/dashlets/user-welcome does not map to a Web Script.
12:12:49,968 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/dashlets/user-calendar does not map to a Web Script.
12:12:49,984 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/dashlets/rssfeed does not map to a Web Script.
12:12:49,984 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/dashlets/alfresco-network does not map to a Web Script.
12:12:50,000 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/dashlets/my-activities does not map to a Web Script.
12:12:50,000 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/dashlets/cmisfeed does not map to a Web Script.
12:12:50,000 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/dashlets/my-profile does not map to a Web Script.
12:12:50,015 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/dashlets/my-sites does not map to a Web Script.
12:12:50,015 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/dashlets/my-tasks does not map to a Web Script.
12:12:50,015 INFO  [org.alfresco.web.scripts.AbstractRuntime] Caught exception & redirecting to status template: Script url /components/footer does not map to a Web Script.
I'm a little lost :o perhaps it gives me the error because I didn't start the virtual server (I've got a warning about it)?

Finally, the web page sends me the messages :

Message:   Script url /components/header does not map to a Web Script.
   
Exception:   org.alfresco.web.scripts.WebScriptException - Script url /components/header does not map to a Web Script.

I precise that I CAN login…But when I submit, the error appears…Alfresco is running well and :
http://localhost:8080/alfresco
http://localhost:8080/studio
are both available.

Any idea please :(

Thanks a lot !

Regards,

Benoit Bedeau

EDIT :
after thinking a while, I remembered that I installed a fr language pack…And some directories were in the wrong place. I reinstalled the language pack and respected the architecture, and now it works ;)

Outcomes