AnsweredAssumed Answered

CIFS + Tomcat5.5 + Debian = no broadcast for CIFS

Question asked by james.t on Dec 5, 2007
Latest reply on Jan 5, 2008 by rjperrella
Hi i've got most of alfresco working except i can't get it to broadcast the netbios name on a network.
I have the typical errors:

04:29:49,038 ERROR [alfresco.smb.protocol] Failed to get local domain/workgroup name, using default of WORKGROUP
04:29:49,040 ERROR [alfresco.smb.protocol] (This may be due to firewall settings or incorrect <broadcast> setting)


I am running tomcat as root
I have tried setting the broadcast manually in the file-servers.xml <broadcast> setting
Samba is not running
I've tried setting the port to 445 instead of the 1445


i can connect with smbclient locally with the server_A netbios name but not from an external server.

also i can connect externally using a DNS name associated to an ip that i set <bindto> in file-servers.xml to.
Obviously i can workaround by assigning a DNS name that matches the NETBIOS name but i'd like to know a proper fix if possible.

Any help please?

Outcomes