AnsweredAssumed Answered

Bloody Painful Install - Alfresco-Labs-3c-Linux-x86-Install

Question asked by lewstherin on Mar 4, 2009
Latest reply on May 20, 2009 by psleeps2000
I am up for any suggestions from anyone and would appreciate any input.

Wow, I mean seriously, wow . . .  :shock:

I have tried everything. I just keep running into not being able to login to blah:8080/share after a "successful" install. I can't believe how obstinate this is being.

Here is scoop:

Installing Alfresco-Labs-3c-Linux-x86-Install on CentOS 4.7 (and also tried a new 5.2 box too get exactly the same)

Following the directions from http://wiki.alfresco.com/wiki/Installing_Labs_3_on_Linux_with_command_line_interface

(I have installed it both in the CLI directly and also X forwarded the GUI client, with exactly the same results. Also note the instructions in the .pdf (Install_Configure_Alfresco_Labs3c.pdf Installing Alfresco on Redhat Linux (excluding JDK))

I then edit /opt/Alfresco/alfresco.sh to point to my java, etc.

I then try to pull up the web page and get the login screen, to which, not matter what I try I am utterly able to log into using admin / admin.  I tried setting up MySQL instead. Same deal. Reinstalled multiple times. Same. Tried setting the update database.scheme to true in the config. Nope. tried the Tomcat bundle (got nowhere with that). Reinstalled again, same. Tried on another clean install of CentOS 5.2. Nope.  Always the result is the same error that the server can not be contacted or the credentials are incorrect. It is impossible to log in after the install finishes.

I search and search through the forums and found many people having the same issue, but no clear solution. I have tried a few things - all to no avail.

I am no java / Tomcat app expert, but this is really insane - and judging from the forum posts I see I am not a alone.

Normally I don't rant so much but wow - this is just really amazing. I installed O3Spaces in about :05 and it works perfectly. I would like to use Alfresco, but the install process appears to have some rather show stopper issues.

I would appreciate any assistance anyone can offer.

Wow.

Here are my Java RPMS

[root@65-110-52-190 Alfresco]# rpm -qa | grep java
sun-javadb-common-10.4.1-3.1
sun-javadb-docs-10.4.1-3.1
sun-javadb-core-10.4.1-3.1
sun-javadb-demo-10.4.1-3.1
sun-javadb-javadoc-10.4.1-3.1
sun-javadb-client-10.4.1-3.1

[root@65-110-52-190 Alfresco]# java -version
java version "1.6.0_12"
Java(TM) SE Runtime Environment (build 1.6.0_12-b04)
Java HotSpot(TM) Client VM (build 11.2-b01, mixed mode, sharing)


[root@65-110-52-190 Alfresco]# /opt/Alfresco/alfresco.sh start
Using CATALINA_BASE:   /opt/Alfresco/tomcat
Using CATALINA_HOME:   /opt/Alfresco/tomcat
Using CATALINA_TMPDIR: /opt/Alfresco/tomcat/temp
Using JRE_HOME:       /usr/java/jdk1.6.0_12/

Nothing useful get logged to alfresco.log, it simply ends with

11:12:46,715 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
11:13:06,153 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework

Outcomes