AnsweredAssumed Answered

Newbie installing and in despair

Question asked by martink1 on Dec 7, 2007
I'm a complete newbie to Alfresco, and don't know Linux or Tomcat very well (though I have been through install processes on Linux/Tomcat before). I've never programmed in Java but I'm reasonably proficient in MySQL and PHP.

I'm trying to install Alfresco on an Ubuntu 7.1 (Gutsy Gibbon) build under Tomcat 5.5, using a MySQL server. Here's where I've gotten so far:

    1) I tried to install Tomcat using the Ubuntu packaging system but without success - for some reason it never wanted to shutdown properly and after uninstalling and reinstalling it was completely lost. So instead I installed it "by hand" using instructions off the Ubuntu web site, and this appears to work. I can use the Tomcat Manager and Administrator, and the "sample applications". I can shutdown and restart Tomcat ok.
    2) I've successfully created a MySQL database server (I've actually got a PHP/MySQL application running already, and I've successfully created an "Alfresco" database, which I can see with the MySQL administrator. I've followed the instructions in the MySQL readme that accompanied the Alfresco WAR.
    3) I've downloaded the Alfresco WAR bundle. I couldn't quite see what to do with it, so I used the Tomcat manager to deploy the Alfresco WAR bundle. This seems to have worked ok because the Tomcat manager shows Alfresco in its list of applications.
Here is where my problem begins. When I try to start the Alfresco application (or when I start Tomcat), after much thinking it fails - the application never gets going. Something must have happened, because when I look in the MySQL database it has clearly been initialised with Alfresco tables. However, when I look at the "Catalina.out" log here is what I see (in the first few lines to do with Alfresco)
7 déc. 2007 17:50:36 org.apache.catalina.startup.HostConfig deployWAR
INFO: Déploiement de l'archive alfresco.war de l'application web
17:50:53,303 ERROR [transform.magick.AbstractImageMagickContentTransformer] ImageMagickContentTransformer not available: Failed to perform ImageMagick transformation:
Execution result:
   os:         Linux
   command:    convert /usr/share/tomcat/temp/Alfresco/ImageMagickContentTransformer_init_source_38604.gif  /usr/share/tomcat/temp/Alfresco/ImageMagickContentTransformer_init_target_38605.png
   succeeded:  false
   exit code:  1
   out:       
   err:        java.io.IOException: convert: not found
17:50:56,343 ERROR [web.context.ContextLoader] Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'serverConnector' defined in class path resource [alfresco/core-services-context.xml]: Invocation of init method failed; nested exception is java.io.IOException: Cannot bind to URL [rmi://localhost:50500/alfresco/jmxrmi]: javax.naming.NameAlreadyBoundException: alfresco/jmxrmi [Root exception is java.rmi.AlreadyBoundException: alfresco/jmxrmi]
Caused by:
java.io.IOException: Cannot bind to URL [rmi://localhost:50500/alfresco/jmxrmi]: javax.naming.NameAlreadyBoundException: alfresco/jmxrmi [Root exception is java.rmi.AlreadyBoundException: alfresco/jmxrmi]
   at javax.management.remote.rmi.RMIConnectorServer.newIOException(RMIConnectorServer.java:814)
   at javax.management.remote.rmi.RMIConnectorServer.start(RMIConnectorServer.java:431)
   at org.springframework.jmx.support.ConnectorServerFactoryBean.afterPropertiesSet(ConnectorServerFactoryBean.java:168)
   at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1118)

Clearly ImageMagick is missing, but apparently there is something else wrong and I am at my wits end to think what. Some suggestions would be very welcome.
MK

Outcomes