AnsweredAssumed Answered

[Installation] - Startup problem

Question asked by marcel_kobain on Dec 20, 2007
Latest reply on Dec 21, 2007 by marcel_kobain
Hello,

I've some difficulties to start Alfresco, sometimes it works sometimes not…
I use Alfresco Community 2.1 with Tomcat 5.5.

See my catalina.log :

< 20 déc. 2007 12:51:24 org.apache.coyote.http11.Http11BaseProtocol init
< INFO: Initialisation de Coyote HTTP/1.1 sur http-8081
< 20 déc. 2007 12:51:24 org.apache.catalina.startup.Catalina load
< INFO: Initialization processed in 4033 ms
< 20 déc. 2007 12:51:25 org.apache.catalina.core.StandardService start
< INFO: Démarrage du service Catalina
< 20 déc. 2007 12:51:25 org.apache.catalina.core.StandardEngine start
< INFO: Starting Servlet Engine: Apache Tomcat/5.5.23
< 20 déc. 2007 12:51:25 org.apache.catalina.core.StandardHost start
< INFO: XML validation disabled
< 20 déc. 2007 12:51:28 org.apache.catalina.startup.HostConfig deployWAR
< INFO: Déploiement de l'archive alfresco.war de l'application web
< 20 déc. 2007 12:52:53 org.apache.catalina.core.StandardContext start
< GRAVE: Error listenerStart
< 20 déc. 2007 12:52:53 org.apache.catalina.core.StandardContext start
< GRAVE: Erreur de démarrage du contexte [/alfresco] suite aux erreurs précédentes
< 20 déc. 2007 12:53:00 org.apache.coyote.http11.Http11BaseProtocol start
< INFO: Démarrage de Coyote HTTP/1.1 sur http-8081
< 20 déc. 2007 12:53:00 org.apache.catalina.storeconfig.StoreLoader load
< INFO: Find registry server-registry.xml at classpath resource
< 20 déc. 2007 12:53:01 org.apache.catalina.startup.Catalina start
< INFO: Server startup in 97162 ms

The problems seems to come with the Alfresco web.xml… (remember that sometimes I manage to lauch Alfresco so…)

See my alfresco.log


11:30:31,784 WARN  [org.springframework.remoting.rmi.RmiRegistryFactoryBean] Could not detect RMI registry - creating new one
11:30:41,097 WARN  [org.alfresco.util.OpenOfficeConnectionTester] A connection to OpenOffice could not be established.
11:30:57,413 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.HSQLDialect.
11:30:57,456 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Alfresco is using the HSQL default database. Please only use this while evaluating Alfresco, it is NOT recommended for production or deployment!
11:31:00,450 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Aucune modification na été apportée au schéma.
11:31:07,805 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: /opt/alfresco/alf_data
11:31:11,250 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Vérification des correctifs à appliquer …
11:31:11,472 INFO  [org.alfresco.repo.module.ModuleServiceImpl] 0 module(s) trouvé(s).
11:31:18,005 ERROR [org.alfresco.smb.protocol] Failed to get local domain/workgroup name, using default of WORKGROUP
11:31:18,005 ERROR [org.alfresco.smb.protocol] (This may be due to firewall settings or incorrect <broadcast> setting)
11:31:18,400 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_03-b05; maximum heap size 253,188MB
11:31:18,401 WARN  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - WARNING - maximum heap size 253,188MB is less than recommended 512MB
11:31:18,402 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Community Network): Current version 2.1.0 (484) schema 64 - Installed version 2.1.0 (484) schema 64

In addition to when I stop Alfresco I've got this message :


Using CATALINA_BASE:   /opt/alfresco/tomcat
Using CATALINA_HOME:   /opt/alfresco/tomcat
Using CATALINA_TMPDIR: /opt/alfresco/tomcat/temp
Using JRE_HOME:       /usr/java/jre1.6.0_03
CompilerOracle: exclude org/apache/lucene/index/IndexReader$1 doBody
CompilerOracle: exclude org/alfresco/repo/search/impl/lucene/index/IndexInfo$Merger mergeIndexes
CompilerOracle: exclude org/alfresco/repo/search/impl/lucene/index/IndexInfo$Merger mergeDeletions

Thanks for your help!

Outcomes