AnsweredAssumed Answered

A connection to OpenOffice could not be established

Question asked by radek.budar on Dec 28, 2007
Hallo,

i have trouble with collaboration Alfresco and OpenOffice. I have instaled OpenOffice (C:\Program Files\OpenOffice.org 2.3) and Alfresco 2.0. After alfresco start a have this warning:

22:30:42,197 WARN  [alfresco.util.OpenOfficeConnectionTester] A connection to OpenOffice could not be established..

(Is this problem really "warning" only???)

I have read Alfresco forum and found any solution for this problem like tihis:

http://forums.alfresco.com/viewtopic.php?p=19982

or

http://forums.alfresco.com/viewtopic.php?t=6146

And no effect :-(

I set OPENOFFICE_PATH variable to "C:\Program Files\OpenOffice.org 2.3\program"

I modified my alftresco.bat,

1)

if not "%OPENOFFICE_PATH%" == "" call "%OPENOFFICE_PATH%\soffice" "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" "-env:UserInstallation=file:///%ALF_HOME_URI%oouser" -nologo -headless -nofirststartwizard

2)
if not "%OPENOFFICE_PATH%" == "" call "C:\\Program Files\\OpenOffice.org 2.3\\program\\soffice" "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" "-env:UserInstallation=file:///%ALF_HOME_URI%oouser" -nologo -headless -nofirststartwizard

3)
if not "%OPENOFFICE_PATH%" == "" call "C:\Program Files\OpenOffice.org 2.3\program\soffice" -accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" -nologo -headless -nofirststartwizard

And no effect…:-(

Please, can you give me any advice? Can I logged more about this problem? How?

Thanks a regards
Radek Budar

Outcomes